
1. What are four foundamental parts of computer ? Explain it with the  help 

of diagram? 

1.Input Unit:  

This unit is responsible for receiving data and instructions from the user or 
other devices. Examples include keyboards, mice, microphones, and 
scanners.  

2.Processing Unit (CPU):  

The CPU is the "brain" of the computer, responsible for interpreting and 
executing instructions received from the input unit or from memory. It 
consists of the control unit (which coordinates operations) and the 
arithmetic-logic unit (ALU) (which performs calculations and logical 
operations).  

3. Memory Unit: 

This unit provides temporary storage for data and instructions that the CPU 
needs to access quickly. It includes RAM (Random Access Memory), which 
is volatile (data is lost when power is off), and cache memory (used for 
even faster data access).  

4. Storage Unit:  

This unit provides permanent storage for data and programs. Examples 
include hard drives (HDDs), solid-state drives (SSDs), and USB flash 
drives.  

5. Output Unit: 

 This unit presents the results of the processing to the user or other 
devices. Examples include monitors, printers, and speakers.  

Key Components and Their Functions: 

 Motherboard: The main circuit board that connects all the components 

together.  

 Power Supply Unit (PSU): Provides power to all the components.  

 Chipset: A set of integrated circuits on the motherboard that control 

communication between the CPU, memory, and other components.  

 

  



Visual Representation: 

A block diagram helps visualize the relationships between these components. You 

can find various block diagrams online that illustrate the flow of data and 

instructions between the input, processing, storage, and output units, as well as the 

role of the CPU, memory, and other essential components.  

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



2.Discuss about the classification of computers based on size and capacity. 

1.Supercomputers:  

These are the largest, fastest, and most expensive computers, designed for 
high-performance tasks like scientific simulations, weather forecasting, and 
complex calculations. They are used by large organizations and 
institutions.  

 

2.Mainframe Computers: 

Mainframe computers are large and powerful, capable of handling massive 
amounts of data and supporting numerous users simultaneously. They are 
used by large organizations like banks, insurance companies, and 
government agencies.  

3.Minicomputers: 

Minicomputers are mid-sized computers, more powerful than 
microcomputers but less powerful than mainframes. They are often used in 
networked environments or by businesses that need a more powerful 
system than a personal computer.  

4. Microcomputers (Personal Computers): These are the most common 
type of computer, used by individuals for general-purpose tasks like word 
processing, browsing the internet, and entertainment. Examples include 
desktops, laptops, and tablets. In addition to size, computers can also be 
classified by their data handling capabilities: 

Digital Computers: 

These computers store data in binary format (0s and 1s) and execute logical and 

mathematical operations. 

Analog Computers: 

These computers process continuously varying data, measuring physical 

quantities like electrical current and voltages. 

Hybrid Computers: 

These computers combine the characteristics of both digital and analog 

computers.  
 

3.what is the meaning of computer generation? How many Computer 

Generations are defined? What technologies were / are used? 

 



Here's a breakdown of the five generations: 

1. First Generation (1940s-1950s): 

Used vacuum tubes for circuitry and were large, slow, and inefficient. Examples: 

ENIAC, UNIVAC. 

2. Second Generation (1950s-1960s): 

Replaced vacuum tubes with transistors, making computers smaller, faster, and 

more reliable. 

3. Third Generation (1960s-1970s): 

Introduced integrated circuits (ICs), which significantly improved speed and 

efficiency while further reducing size. 

4. Fourth Generation (1970s-present): 

Used microprocessors, enabling the development of personal computers (PCs). 

5. Fifth Generation (present and beyond): 

Focuses on artificial intelligence (AI), machine learning, and other advanced 

technologies, making computers more intelligent and powerful.  
 

4.Differentiate between Volatile & Non- Volatile memories. 

1.  Volatile Memory: 

 Data Loss: Lacks the ability to retain stored data when power is turned off.  

 Speed: Generally faster than non-volatile memory.  

 Cost: Typically more expensive per unit of storage.  

 Purpose: Used for temporary storage, like storing the data currently being 

used by a program (e.g., RAM).  

 Examples: RAM, Cache memory.  

 Non-Volatile Memory: 

 Data Persistence: Retains data even when power is removed. 

 Speed: Slower than volatile memory. 

 Cost: Generally cheaper per unit of storage. 

 Purpose: Used for long-term storage of data and programs (e.g., hard drives, 

flash memory). 

 Examples: ROM, Hard drives, Flash memory.  
 

 



5. Distinguish among system software, application software and open 

source software on the basic of their features. 

 

System Software: 

Function: 

Controls and manages the computer's hardware and software resources, 

enabling other programs to run.  

Examples: 

Operating systems (like Windows or Linux), device drivers, and utility 

software.  

Features: 

Provides a platform for running application software, manages hardware 

resources like memory and CPU, and handles input/output.  

 

Application Software: 

 

Function: Performs specific tasks for users, such as writing documents, 

browsing the web, or playing games.  

Examples: Word processors, web browsers, image editors, and video 

games.  

Features: Designed to meet user-specific needs, can be customized, and 

often has a user-friendly interface.  

 

Open-Source Software: 

 Function: Allows users to view, modify, and distribute the software's source 

code.  

 Examples: Many web servers, operating systems, and office suites.  

 Features: Promotes collaboration and community-driven development, often 

free to use, and allows for customization.  

Key Differences: 

 Focus: 

System software focuses on managing the computer's hardware and 

software, while application software focuses on specific user tasks.  

 Access to Source Code: 



Application software typically has restricted or proprietary access to its source 

code, while open-source software makes its source code freely available.  

Development: 

Application software is often developed by a single organization, while open-source 

software is often developed collaboratively by a community.  
 

6. a) Create a file in MS word to insert a paragraph about yourself and 

save it with file name”yourself”. Describe all  steps involved in it. 

1. 1. Open Microsoft Word: 

Launch the Word application on your computer. 

2. 2. Create a new document: 

 Click on the "File" tab, then select "New". 

 Choose "Blank document" from the options. 

3. 3. Write a paragraph about yourself: 

Start typing your paragraph in the new document. You can describe your 

interests, skills, experience, or anything else you'd like to include. 

4. 4. Save the document: 

 Click on "File" again, then select "Save As". 

 Choose a location to save the file (e.g., your Documents folder, 

Desktop). 

 In the "File name" field, type "yourself". 

 Ensure the "Save as type" is set to ".docx" (Word document) or 

another suitable format. 

 Click "Save". 

Steps for creating a new file and saving: 

1. Open Microsoft Word. 

2. Create a new document: Go to "File" > "New" > "Blank document". 

3. Start typing: Begin typing your paragraph. 

4. Save the document: 

5. Go to "File" > "Save As." 

6. Choose a location to save. 

7. Enter "yourself" as the filename. 

8. Click "Save."  



6.b) Write Steps  regarding followings 
 

 To change the font style 

 To change the font size 

 To change the font colour 

 To  highlight the line that reads”need to get  IMS’s address.” 

Changing the Font Style: 

1. Highlight the text: Select the text you want to change.  

2. Navigate to the "Font" group: On the "Home" tab (or similar depending on 

your software), locate the "Font" group of buttons.  

3. Select the desired font: Click the dropdown arrow next to the font name and 

choose the font style you prefer from the list. (e.g., Times New Roman, Arial, 

Calibri).  

Changing the Font Size: 

1. Highlight the text: Select the text you want to change.  

2. Locate the font size dropdown: In the "Font" group, next to the font 

selection, there will be a dropdown list showing font sizes.  

3. Choose the desired size: Click the arrow and select the desired font 

size. (e.g., 12, 14, 16)  

Changing the Font Color: 

1. Highlight the text: Select the text you want to change. 

2. Click the color selection button: In the "Font" group, there will be a button 

or icon representing the current font color. Click on it to open a color palette. 

3. Select a color: Choose the desired color from the palette.  
 

7. Create a file in MS word for the following documents and save it witch 

file name ms world. Describe all steps involved in it. 

1. Open Microsoft Word: Launch the Microsoft Word application on your 

computer. 

2. Create a New Document: 

o Click on the "File" tab in the Word ribbon. 

o Select "New" from the menu. 

o Choose "Blank document" from the options. 



3. Type or Paste the Content: 

Type the provided text into the new document:Code 
 

Alternatively, you can copy and paste the text into the document.  

1. Save the Document: 

o Click on the "File" tab in the Word ribbon. 

o Select "Save As..." from the menu.  

o Choose a location on your computer where you want to save the document (e.g., 

Desktop, Documents).  

o In the "File name" box, type "ms world" (without the quotes). Make sure the file 

extension .docx is automatically added.  

Click "Save". 

 

 

8. Create a File in MS word for the following document and save it with 
file name ‘equations’. Describe all steps involved in it. 
 

  

1. Open MS Word: Launch the Microsoft Word application on your computer. 

2. Insert Equations: Go to the "Insert" tab, click on "Equation", and then select 

"Insert New Equation" or use the shortcut Alt + =. 

3. Type the Equations: Use the Equation Editor tools (or insert directly) to type the 

equations: 

o X2 + y5 = 30 

o Z3 + Q4 = 50 

o A2 + b8 = X2 + Y8 

4. Save the File: Go to "File", then "Save As". 

5. Choose a Location: Select the folder where you want to save the file. 

6. Enter File Name: Type "equations" in the "File name" field. 

7. Select File Format: Ensure the file format is set to ".docx" (Microsoft Word 

Document). 

8. Click "Save": Click the "Save" button to save the file 
  



9. Create a file in MS word that convert existing highlight text to table 
as shown below and save it as file name ‘text to table’.Describe all steps 
involved in it. 

 

1. Select the text: Highlight the text you want to convert to a table.  

2. Access the Table command: Go to the "Insert" tab on the ribbon, and then 

select "Table".  

3. Choose "Convert Text to Table": In the dropdown menu that appears, select 

"Convert Text to Table".  

4. Set the table size: A dialog box will appear. Here, you can specify the number of 

columns and, if needed, the number of rows.  

5. Specify the delimiter: Determine what character or symbol separates the data 

within each row that you want to be in a different column.  

6. Click "OK": Once you've set the table size and delimiter, click "OK".  

 

10. Create a file in MS Word to insert a table in the document. Describe 
all steps involved in it. 
 

For a basic table, click Insert > Table and move the cursor over the 

grid until you highlight the number of columns and rows you want. 

For a larger table, or to customize a table, select Insert > Table > 

Insert Table. Tips: If you already have text separated by tabs, you 

can quickly convert it to a table. 

 

11.Create a following worksheet in Ms Excel and Save it with name Book  

 

 

 

 

 

 

 



 

12.Calculate the following things of a range(C2:C11) of data in the 

worksheet created in question no 10. 

What you're solving for 

Calculating the sum, average, maximum, and minimum values of a range 
of cells in a worksheet. 

What's given in the problem 

 Range of cells: C2:C11 

Helpful information 

 AutoSum is a function in spreadsheet programs that automatically adds up a range 

of numbers. 

 Average is the sum of the numbers divided by the count of numbers. 

 Maximum is the largest number in a set. 

 Minimum is the smallest number in a set. 

How to solve 

Use the appropriate functions in the spreadsheet program to calculate the 

sum, average, maximum, and minimum values of the specified range. 

13 a) Describe various steps involved in the following 

.  

Drag to adjust: Click and drag the column boundary to the desired width.  

Alternatively, you can use the menu options: 

Select the column(s): Highlight the column(s) you want to modify.  

Access the column width settings: 

Through the ribbon: Go to the "Home" tab, click "Format" in the "Cells" group, and 

select "Column Width".  

Right-click: Right-click on the column header and select "Column Width".  

Enter the desired width: Type the desired column width in the dialog box and click 

"OK".  

To modify the row height of a worksheet: 

. 

Drag to adjust: Click and drag the row boundary upward or downward to the 

desired height.  



Alternatively, you can use the menu options: 

.  

Access the row height settings: 

Through the ribbon: Go to the "Home" tab, click "Format" in the "Cells" group, and 

select "Row Height".  

Enter the desired height: Type the desired row height in the dialog box and click 

"OK".  

To delete rows and columns of a worksheet: 

Select the rows or columns to delete: Click and drag to select the rows or 

columns you want to delete.  

You can delete using the keyboard shortcuts: 

Delete a single row or column: Right-click on the row or column header and select 

"Delete".  

Delete multiple rows or columns: Select the rows or columns, press the "Delete" 

key on your keyboard.  

You can also delete using the ribbon: 

Go to the "Home" tab: Click the "Home" tab on the ribbon. 

Click "Delete": In the "Cells" group, click the "Delete" button. 

Choose the deletion option: Select "Delete Cells", "Delete Columns", or "Delete 

Rows" depending on what you want to delete.  
 

13 b) Describe following terms in the worksheet 

Cell Address: 

 A cell address is a unique identifier for a cell in a spreadsheet, composed of a 

column letter (A, B, C, etc.) and a row number (1, 2, 3, etc.). 

 For example, "A1" refers to the cell at the intersection of column A and row 1. 

 Spreadsheets use cell addresses to refer to specific cells within a formula or in other 

contexts.  

Relative Reference: 

 A relative reference is a cell address that changes when a formula is copied or 

moved to another cell.  

 The change is based on the relative position of the new cell to the original cell.  



 For instance, if you copy the formula =A1+B1 from cell C1 to C2, the relative 

references in the formula will update to =A2+B2.  

 Relative references are the default type in spreadsheet programs.  

Absolute Reference: 

 An absolute reference is a cell address that does not change when a formula is 

copied or moved.  

 It's identified by a dollar sign ($) before both the column and row, like $A$1.  

 When you copy a formula containing an absolute reference, the reference remains 

fixed, even if the cell is moved.  

 For example, if you use $A$1 in a formula and copy it, the formula will always refer to 

cell A1, regardless of where it's placed.  

 

14 a) What tools are available to customize our powerpoint 
presentations? 

 

Built-in PowerPoint Features: 

 Designer: This AI-powered feature (available with Microsoft 365) suggests design 

ideas based on the content on your slides.  

 Themes: Choose from a variety of pre-designed themes or create your own, 

customizing fonts, colors, and background styles.  

 Slide Layouts: Select from various layouts to suit different types of content, 

including placeholders for text, images, and more.  

 Transitions and Animations: Add visual effects to your slides to make them more 

engaging.  

 SmartArt: Convert text into visually appealing graphics using SmartArt.  

 Backgrounds: Set a background image or color for your slides.  

 Fonts and Colors: Customize the fonts and colors of text and other elements.  

 Insert: Insert a variety of objects like pictures, charts, tables, icons, and more.  

2. External Tools: 

 ShapeChef: 

A library of icons that can be used with PowerPoint.  

 SlideProof: 

Checks for errors on slides, including language, font inconsistencies, and 

formatting issues.  



 

14 B ) Write the steps for the following action for creation of power point  
presentation 

 Open PowerPoint and Start a New Presentation 

 Open PowerPoint. 

 Select "Blank Presentation" from the available options, or from the File menu choose 

"New" then "Blank Presentation".  

Step 2: Save Your Presentation 

 Go to the File menu and select "Save As". 

 Choose a location on your computer to save the file. 

 Enter the filename "lab1" and ensure the file type is set to "PowerPoint Presentation 

(*.pptx)". 

 Click "Save".  

Step 3: Customize the First Slide (Title Slide) 

 In the first slide, type the name of your college in the title area (usually a large text 

box). 

 In the subtitle area (usually a smaller text box below the title), enter your first name 

and last name.  

Step 4: Add a New Slide with Title and Content 

 Go to the "Home" tab in the ribbon. 

 Click "New Slide" (or use the shortcut Ctrl+M). 

 Select the layout you want for the new slide. A common choice is "Title and 

Content". 

 Type the title of your new slide in the title box. 

 Type your content into the text box (or insert images, charts, etc., depending on the 

slide layout).  

 

15. Write steps for creation of a set powerpoint slides that demonstrates 
the tools of powerpoint. It should include the following things 
 

1. Step 1: Launch the PowerPoint Program. ... 
2. Step 2: Choosing a Design. ... 
3. Step 3: Create Title Page. ... 
4. Step 4: Add More Slides. ... 
5. Step 5: Add Charts, Pictures, Graphs, Etc. ... 

 



6. Step 6: Add Transitions. ... 
7. Step 7: Changing the Order. ... 
8. Step 8: Play the Presentation. 

Part 2 

16. What is the difference between Machine Language and High Level 

Language? 

Machine Language: 

 Readability: Not human-readable; consists of binary code (0s and 1s). 

 Abstraction: No abstraction; directly represents the instructions the CPU executes. 

 Execution: Executed directly by the CPU without translation. 

 Examples: Machine code is specific to a particular processor architecture. 

 Purpose: Used to define the fundamental operations of a computer.  

High-Level Language: 

 Readability: Designed to be human-readable, using English-like keywords and 

symbols.  

 Abstraction: Provides a high level of abstraction, hiding the details of the underlying 

hardware.  

 Execution: Requires a compiler or interpreter to translate the code into machine 

language.  

 Examples: Python, Java, C, Fortran.  

 Purpose: Used by programmers to write programs, which are then translated into 

machine language for the computer to execute.  
 

17. Discuss about different data types of C programming Language. 

Types Description Data Types 

Primitive Data 

Types 

Primitive data types are the most basic data types 

that are used for representing simple values. 

int, char, float, 

double, void 

Derived Types  

The data types that are derived from the 

primitive or built-in datatypes are referred to as 

Derived Data Types. 

array, pointers, 

function 

https://www.geeksforgeeks.org/c-derived-data-types/


Types Description Data Types 

User Defined 

Data Types  

The user-defined data types are defined by the 

user himself. 

structure, 

union, enum 

 

18.Find the output of the following expressions 

a) x=20/5*2+30-5 

Output= 33 

b)Y=30 –(40/10+6)+10 

Output=30 

c)Z=40*2/10-2+10 

Output=16 

19.Describe the syntax of the following statements  

a) If-else statement 

he if-else statement in C provides a way to execute different blocks of code based on 

a condition. Here's its syntax: 

C 

 

if (condition)  

{ 

 }  

else  

{ 

 } 

 

 if: Keyword that begins the statement. 

 condition: An expression evaluated to determine if it's true (non-zero) or false (zero). It 

is enclosed in parentheses (). 

https://www.geeksforgeeks.org/c-user-defined-data-types/
https://www.geeksforgeeks.org/c-user-defined-data-types/


 {}: Curly braces define the code blocks. The first block is executed if the condition is true, 

and the second block (after else) is executed if the condition is false. 

 else: Optional keyword. If omitted, and the condition is false, no code block is executed.  

A variation is the else if statement, allowing for multiple conditions: 

C 
If 

 (condition1)  

{ 

 if true 

} else if (condition2)  

{ 

true 

}  

else  

{ 

false 

} 

 else if: Allows for checking additional conditions if the preceding if or else if conditions 

are false. 

 Multiple else if statements can be chained together. 

 The else block at the end is optional and executes if none of the preceding 

conditions are true. 
 

b) for loop C 

for (initialization; condition; update) 

 { 
} 



Initialization 

This expression is executed only once at the beginning of the loop. It typically initializes a 

loop counter variable. 

Condition 

This expression is evaluated before each iteration. If it evaluates to true (non-zero), the loop 

body is executed. If it evaluates to false (zero), the loop terminates. 

Update  

This expression is executed after each iteration. It usually increments or decrements the 

loop counter variable. 

These three expressions are optional, but the semicolons separating them are 

mandatory. If the condition is omitted, it is assumed to be always true, resulting in 

an infinite loop unless a break statement is used to exit the loop 

 

c)while loop  C 

while (condition)  

{ 

} 

 while: This keyword initiates the while loop. 

condition: This is a boolean expression enclosed in parentheses. The loop 

continues to iterate as long as this condition evaluates to true. If the 

condition is initially false, the loop body will not be executed at all. 

{}: The curly braces enclose the block of code that constitutes the body 
of the loop. This code is executed repeatedly as long as the condition 

remains true.  

A typical while loop involves the following steps: 

 Initialization: Variables used in the condition are initialized before the loop begins. 

 Condition Check: The condition is evaluated. 

 Execution: If the condition is true, the code within the loop's body is executed. 

 Update: Variables involved in the condition are updated within the loop's body to avoid 

infinite loops. 

 Repetition: Steps 2-4 are repeated until the condition becomes false. 

 

 



Example: 

#include<stdio.h> 

int main() { 

  int i = 1; 

   while (i <= 5) { 

    printf("%d\n", i); 

        i++; 

    } 

    return 0; 

} 

In this example, the loop iterates as long as the variable i is less than or equal to 5. 

In each iteration, the current value of i is printed, and i is incremented. The loop 

terminates when i becomes 6. 

 

d) do while loop  C 

do { 

    } while (condition); 

Explanation:  

1. do: Marks the beginning of the do-while loop. 

2. { ... }: Encloses the code block that will be executed repeatedly. 

3. while: A keyword that introduces the condition. 

4. (condition): A boolean expression. If the condition is true, the loop continues; if 

false, the loop terminates. 

5. ;: A semicolon at the end of the while statement to mark the end of the do-while loop. 

 

How it works: 

6. The code within the do block is executed once.  

7. Then, the while condition is evaluated.  

8. If the condition is true, the code in the do block is executed again.  

9. Steps 2 and 3 are repeated until the condition becomes false.  



10. Key difference from a while loop: 

The do-while loop guarantees that the code within the do block will be executed 

at least once, even if the condition is initially false. In contrast, a while loop might 

not execute its code block at all if the condition is false from the start. 

 

20. Find the Output of the following program segments 

a) 

#include< stdio.h> 

Int main() 

{ 

Int i; 

For (i=1; i<2; i++) 

{ 

Printf(“IMS Ghaziabad\n”); 

} 

} 

Output : IMS Ghaziabad 

b) 

#include<stdio.h> 

Int main() 

{ 

Int I =1; 

While ( i<=2) 

{ 

Printf(“IMS Ghaziabad\n”); 

i = I + 1; 

}} 

Output : IMS Ghaziabad 

IMS Ghaziabad 

 



c) 

#include <stdio.h> 

Void main() 

{ 

Int a =10,b=100; 

If(a>b) 

Printf(“largest number is %d\n”,a); 

Else 

Printf(“largest number is % d\n”,b); 

} 

Output : largest number is 100 


