CCA-101: fundamentals Of IT & Programming

Assignment -1

Q1. What are the four fundamentals part of computer? Explain it with the help of diagram.

Ans:

A\ 4

The four fundamental part of computer are:

1 Input Devices : Computer systems use many devices for input purpose. Input devices include the mouse, input
pen, touch screen, microphone. Regardless of the type of devices used, all are components for interpretation and
communication between people and computer systems.

2 Central Processing Unit (CPU): It is brain of the computer without this unit computer unable to process.

3 Output Devices: Output Devices is used to show the result of the instructions. Example Monitor, printer,
headphone etc.

4 Memory Unit: A memory unit is the collection of storage units or devices together. The memory unit storage the
binary information in the form of bits.

Q2. Discuss about the classification of computer based on size and capacity?
Ans: Based on size and capacity, computers are classified as

1) Super computer: They have thousands of processor. Because of their extraordinary speed, accuracy and
processing power, supercomputers are well suited for solving highly complex problems and huge amount of
calculations.

e.g. JAGUAR, ROADRUNNER etc.

2) Mainframe Computer: They are very large often filling an entire room and can process thousands of
millions of instruction per second. They are capable of supporting hundreds to thousands of users simultaneously.
Functions performed by mainframe include flight scheduling, reservation and ticketing for an airline etc.

3) Minicomputers: They are much smaller than mainframes. They are typically larger, more powerful and
more expensive than desktop computers. Users connect to the server through a network by using desktop
computers.

e.g. apple | pod, CDC 160A

4) Microcomputers: They are the most frequently used type of computers. It is also known as personal
computers.

e.g. desktop computers, laptop.

Q3. What is the meaning of computer generation? How many computer Generations are Defined? What
technologies were/are used?

Ans: generation in computer terminology is change in technology of a computer which were being used




1. It is a computer storage that only maintains its 1. it is a type of computer memory that has the
data while the device is powered. capability to hold saved off.

2. E.g. RAM.

3. Primary memory has limited storage capacity 2. E>g. ROM, hard disk, floppy disk, etc.

and is volatile.
3. Secondary memory provides permanent storage

of data and in bulk quantity.




3. We move cursor over the size various font sizes. A live preview of the font size will appear on the document.
4. 4. Left click the font size we want to use. The font size will change in the document.

Step of change the font color:

1. We select the text we want to modify.

2. Left click the drop-down arrows next to the font color box on the home tab. The font color menu appears.
3. We move cursor on various font colors. A live preview of the color will appear in the document.

4. 4. Left click the font color we want to use. The font color will change in the document.

Step to highlight the line:

1. We select the line that reads “need to get IMS’s address”.
2. We click the highlight command and select yellow color in the font group on the home tab.

Q7. Create a file in MS-Word for the following document and save it with file name “ms-word”. Describe all steps
involved in it.

MS WORD

is a widely used commercial word processor developed by Microsoft.

MS word is application software, which is capable of

e Editing,
° and

e  Printing any type of document
Ans: MS Word
MS Word is a wider used commercial word processor developed by Microsoft.
MS word is application software, which is capable of

e Creating

e Editing

e Saving

e  Printing any type of document

The steps involved are:

1. We click the Microsoft office button.

2. We select new. The new document dialog box appears.

3. We select blank document under the blank and recent section. It will be highlighted by default.

4. We click create. A new blank document appears in the word window.

5. We create the given document from the question.

6. We select the text “MS word” to change the font size by clicking on the font sixe box on the home tab.
7. We select the text “MS word” to change the font color into red by clicking on the font color menu.

8. We select the text word processor and underline it by clicking the underline command in the font group the
home tab.

9. We select the text “MS word” to change the font style into italic by clicking italic command.

10. We select the text we want to format as a list and click on the bullets command on the home tab.




Select the text you want to convert
Select the Insert Tab.

Click on Table command. A dialog box appears.
Click on Convert Text to Table, a new dialog box appears here set number of columns.
Click on OK Finally Select text convert in a table.




5. We click ok. Then the text appears in a table.

Q10. Create a file in MS-word to insert a table in the document. Describe all steps involved in it.

Ans:

The steps are:

1. We place our insertion point in the document where we want our table to appear

2. We select the insert tab

3. We click the table command

4. We dra

g our mouse over the diagram squares to select the number of columns and rows in the table.

5. Left click our mouse and the table appears in the document.

6. We enter the text into the table.

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’.

Roll No | Name Marks
1|nl 60
2| n2 70
3|n3 80
4| n4 90
5| n5 40
6 | N6 40
7 | n7 50
8| n8 77
9| n9 88
10 | n10 55
Ans:
sum 650
average 65
Maximum 90
Minimum 40

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet create in question no 10.

YV V V V

The sum of the marks using AutoSum in a range of cells (C2:C11)
Average of the marks in a rage of cells (C2:C11)

Highest marks in a range of cells (C2:C11)

Minimum marks in a range of cells (C2:C11)




1|nl 60
2| n2 70
3|n3 80
4| nd 90
5| n5 40
6 | N6 40
7| n7 50
8| n8 77
91| n9 88
10 | n10 55
Ans:
sum 650
average 65
Maximum 90
Minimum 40

Q13. a) Describe various steps involved in the following

» To modify column width of a worksheet
» To modify the row height of a worksheet
» To delete rows and columns of a worksheet

Q13. b) Describe following terms in the worksheet

» Absolute reference and relative reference in formula
» Cell address

Ans: a) to modify column width of a worksheet:

l. Select a column or a range of column.

Il Select a Home tab and in the Cells group, select Format.
M. Click on Column width and type the width for column.
V. Select OK.

To modify the row height of a worksheet:

I Select a row or a range of rows.

Il. Select a Home tab and in the Cells group, select format.
. Click on Row height And type the height for now.
V. Select OK.

To delete rows and columns of a worksheet.

l. Select the cell you want to delete within the column or row.
Il Select home tab. And in cells group click on Delete Sheet Column or Row.
OR
Select the desire row or column.

b):
Absolute Reference:

An absolute reference in excel means there is a fix point of reference applied to a cell or a formula. This is so
the return value will always stay the same no matter where the cell or formula moves to — within the same sheet
or across different sheet.




This refers to a fix point of reference is a constant, and involves the use of dollar sign S in the formula (i.e.,
everyone is to receive the same bonus payout, so the amount $1500 is constant in this situation).

Absolute reference:

It is the default cell reference in Excel. It is simply the combination of column name and row number without any
dollar $ sign. When you copy the formula from one cell to another the relative cell address changes depending on
the relative position of column and row.C1, D2, E4, etc. are examples of relative cell references are used when we
want to perform a similar operation on multiple cells the formula must change according to the relative address of
column and row.

This refers to a relative point of reference, is constantly changing and dollar sign (S) is absent in the formula (i.e.,
when each unit price and quantity are deference variables, there’s no constant in the calculation.

Cell Address:
A cell address is a combination of column letter and a row number that identifies a cell on a worksheet.

For example, Al refers to the cell at the intersection of column A and row 1;B2 refers to the second cell in column
B, and so on.

When used in formula, cell references help Excel find the value the formula should calculate. For instance,
To pull the value of Al to another cell, you use this simple formula:
=Al
To add up the value in cells A1 and A2, you use this one:
=A1+A2
Q14. A) What tools are available to customize our Power Point presentation?
B) Write the steps for the following action for creation of power point presentation

Open a Blank presentation

Save the presentation as Lab1.pptx

Add a Title to the first slide: the name of your college
Type your first name and last name in the Subtitle section
Adda New Slide which has a title and Content

YV VYV VY VY

Ans:

a) Tools available to customize our Power Point presentation are:
a) Perspector

b) Pivot viewer

c) Autodesk 3DS Max

d) VisualBee Power Point Add —in
e) SmartArt

f) Animation and Transition

g) Wordle

h) CA coo

i) Oomfo

j) Clip champ

b) Ans:

To open blank presentation:

I. Open Power point presentation using ‘Run’ command ( window key + R).




. Select the ‘Blank Presentation’. It is opened.
Save the presentation on Labl. pptx:
. Select the ‘File’ on tab bar.
II. Click on ‘Save As’ option.
1. Click on document/Desktop as your choice.
- Add a Title to the first Slide: the name of your college.
. Left click on the ‘Click to Add Title’ section on the first slide.
Il. Type the name of your college.
- Type your first name and last name in the subtitle section:
I. Left click on the ‘Click to Add Subtitle’ section.
Il. Type your first name and last name.
- Add a new slide which has a title and content:
I. Select the Home tab.
II. Click on the dropdown button of the ‘New Slide’ on toolbar.
Ill. Select the slide having ‘Title and content’. It is added.

Q15. Write steps for creation o0f a set of Power Point slide that demonstrates your skill to use the tools of
PowerPoint. It should include the following things

> Title slide &bullet list
> Insert Excel sheet
» Clip art and Text

> Title slide and bullet list:
1. Open PowerPoint Presentation.
2. Select the Home tab.
3. Click at the dropdown button ‘New Slide’ at toolbar.
4. Select the slide having Title slide and bullet list.
> Insert Excel sheet:
1. Open the slide where you want to insert the Excel sheet.
2. Select the ‘Insert tab’. And click on ‘Object’ on tool bar.
3. Select the ‘Microsoft Excel Worksheet’ object type.
4. Click the ‘OK’ button.
» Clip Art and text:
1. Select the Insert tab.
2. Select the ‘Pictures’ or ‘Online Pictures’ on tool bar.
3. Choose the appropriate art for the topic.
4. Click on the ‘Insert’ button.
> Slide show effects:
1. Select ‘Design Tab’ for Themes, Variants and Slide size.
2. Select ‘ Transition tab’ for Cut, Fade, Push, Wipe, split, Reveal, Shape, Flash, etc. for slide effect.




1. A computer programming languages
consisting of binary instruction which a
computer can respond to directly

2. It requires no translator to translate
the code. It is directly understood by
the computer

3. This languages makes fast and

efficient use of the computer

1. it is programming languages that
enables development of a program in a
much more user friendly programming
context

2. It takes additional translation time to
translate the source code to machine
code

3. They are programmer friendly




Else block of statement;
}
b) For loop is similar to while loop. Basic syntax of for loop is as follows:
For (expression 1; expression 2; expression3)
{
Block of statement
}
In the above syntax
Expression 1- initializes variables.
Expression 2- conditional expression as long as this condition is true, loop will keep executing.
Expression 3- it is modifier which increase or decrease the value of the variable.
c) While loop
Basic syntax of while loop is as follows

While (condition)

Single statements

OR while (condition)
{
Block of statements
}
d) Do- while loop.

Do while loop is just like a while loop expert that the text condition is checked at the end of the loop rather than
the start. This has the effect that the body of the loop are always executed at least once

Basic syntax of do- while loop is as follows
Do
{
Single statement
Or
Block of statements
} while (condition)

Q20. Find the output of the following program segments

a) b) c)
#include <stdio.h> #include<stdio.h> #include<stdio.h>
Int main() Int main() Void main()
{ { {
Int 1; Inti=1; Int a=10, b=100;
For (i=1;i<2;i++) While (1<=2) If(a>b)
{ { Prinft(“Largest number is %d\n”

Prinft(“IMS Ghaziabad\n”);
}
}

Prinft(“IMS Ghaziabad\n”);
}
}

,a);
Else
Prinft(“Largest number is
%d\n” ,b);
}




Ans: a) 1
b) 2

¢) b=100






