
  CCA-101: Fundamentals of IT & Programming Assignment -1 

Q1: What are the four fundamental parts of computer? Explain it with the help of diagram 

 The four fundamental parts of a computer are: 

 The Input Unit,  

 The Central Processing Unit (CPU), 

 The Memory Unit, And  

 The Output Unit.  

These units work together to perform the core functions of data input, processing, storage, and output.  

 

 

 

 

 

 

 

Q2: Discuss about the classification of computers based on size and capacity. 

 Computers are classified based on size and capacity into 

 Supercomputers, 

 Mainframe computers,  

 Minicomputers, and  

 Microcomputers. 

 Supercomputers are the largest and most powerful, followed by Mainframes, then Minicomputers, and 

finally, Microcomputers, which are the smallest and most personal 

Q3: What is the meaning of computer generation? How many Computer Generations are defined? What 

technologies were/are used? 

 In the context of computing, "computer generation" refers to a distinct period in the history of 

computer technology, characterized by advancements in hardware, software, and overall computing 

capabilities.  

There are generally five defined generations of computers, each distinguished by the dominant technology 

used in its construction.  



These generations represent a significant evolution in computing, moving from large, room-sized machines 

with limited capabilities to smaller, faster, and more powerful devices capable of performing complex tasks, 

including those related to AI and quantum mechanics. 

Q4: Differentiate between Volatile & Non- Volatile memories. 

 Volatile memory loses its stored data when the power supply is interrupted, while non-volatile 

memory retains data even when the power is off. Volatile memory, like RAM, is used for temporary storage 

and quick access. Non-volatile memory, like ROM and hard drives, is used for long-term data storage.  

 

Volatile memories Non-volatile memories 

 Requires continuous power to maintain 

data.  

 

 Retains data even when power is off.  

 

 Data is lost when power is turned off.  

 

 Examples include ROM (Read-Only 

Memory), hard drives, and flash memory.  

 

Examples include RAM (Random Access 

Memory) and cache memory 

 Slower and more expensive per unit size 

than volatile memory.  

 

 Faster and less expensive per unit size than 

non-volatile memory.  

 

 Used for long-term storage of data and 

programs, such as operating systems, files, 

and applications.  

 

  

 

Q5: Distinguish among system software, application software and open source software on the basis of their 

features. 

System software manages the computer's hardware, application software performs specific tasks for users, 

and open-source software is characterized by publicly accessible source code.  

System Software: 

 Purpose: Designed for users to perform specific tasks or solve particular problems.  

 Examples: Word processors, web browsers, spreadsheets, game engines, and customer relationship 

management (CRM) software.  

 Features: User-friendly interface, task-specific functionalities, and often customizable for individual needs.  

 

Open Source Software: 



 Purpose: Software with source code freely available for users to view, modify, and distribute.  

 Examples: Linux, Android, Apache Server, MySQL.  

 Features: Collaboration and community involvement in development, transparency, and potential for faster 

bug fixing.  

 

Application Software: 

 Purpose: Designed for users to perform specific tasks or solve particular problems.  

 Examples: Word processors, web browsers, spreadsheets, game engines, and customer relationship 

management (CRM) software.  

 Features: User-friendly interface, task-specific functionalities, and often customizable for individual needs.  

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with file name “yourself”. Describe 

all steps involved in it. 

Open Word, create a new document, type your paragraph, and then save the file with the desired name. 

Here's a step-by-step guide: 

1. Open MS Word and create a new document: 

 Open the MS Word application on your computer. 

 Click on "New" or "Blank document" to start a new document. 

 

2. Type your paragraph: 

 Enter your paragraph about yourself in the new document. 

 Consider including information like your name, profession, hobbies, and any other relevant details you'd 

like to share. 

  

3. Save the file: 

 Go to "File" in the top menu. 

 Select "Save As". 

 Choose a location on your computer where you want to save the file (e.g., Desktop, Documents). 

 In the "File name" field, type "yourself" (without the quotation marks). 

 Click the "Save" button.  

 

4. Verify the save: 

 Ensure the file is saved correctly in the chosen location.  



 

Q6 b) Write steps regarding followings  To change the font style  To change the font size  To change the font 

color  To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 

b) Formatting Text in MS Word 

1. Change Font Style: 

 Go to the "Home" tab on the ribbon. 

 Select the text you want to change. 

 In the "Font" group, click the arrow next to the "Font" box to see a list of available fonts. 

 Choose your desired font style 

 

2. Change Font Size: 

 Select the text. 

 In the "Font" group, click the arrow next to the "Font Size" box to see a list of font sizes.  

 Choose your desired font size. 

 

3. Change Font Color: 

 Select the text. 

 In the "Font" group, click the "Font Color" button. 

 Choose the desired color from the color palette. 

 

4. Highlight Text (In Yellow): 

 Select the text you want to highlight. 

 Go to the "Home" tab. 

 In the "Font" group, click the "Highlight Color" button. 

 Choose "Yellow" from the color palette.  

 
Q7. Create a file in MS-Word for the following document and save it with file name ‘ms_word’. Describe all steps 

involved in it. 

To create a new file (document) in MS Word, you can either start with a blank document or choose a 

template. You can access the "New" option by clicking on the "File" tab, selecting "New", and then 

choosing either "Blank document" or browsing through available templates. Alternatively, you can use the 

keyboard shortcut Ctrl + N to create a new blank document.  

Here's a more detailed breakdown: 

1. Starting with a Blank Document: 

 Open Word: Launch Microsoft Word. 

 File Tab: Click on the "File" tab. 

 New: Select "New". 



 Blank Document: Choose "Blank document". A new blank document will appear in a new window.  

 

2. Starting with a Template: 

 Open Word: Launch Microsoft Word. 

 File Tab: Click on the "File" tab. 

 New: Select "New". 

 Templates: Choose a template from the list or search for one. 

 Create: Select the template you want to use and click "Create".  

 

3. Using the Shortcut: 

 Press Ctrl + N: Press the Ctrl and N keys simultaneously on your keyboard to quickly create a new blank 

document.  

 

4.How to save a Word document 

 Select "File" ... 

 Select "Save" or "Save as" ... 

 Choose a location for your file. ... 

 Choose a file name. ... 

 Select the format for your file. ... 

 Use the shortcut save feature to save your document in the future. 

Q8. Create a file in MS-word for the following document and save it with file name ‘equations’. Describe all steps 
involved in it. 

open Word, create a new blank document, enter your text, and then save it as 
"equations" with a suitable extension like .docx.  

x2+ Y5 = 30, 

Z
3 + Q4=50, 

A2+ B8= X2 + Y
8 

 

Q9. Create a file in MS-word that convert existing highlight text to table as shown below and save it as 

file name ‘text_to_table’. Describe all steps involved in it. 

 



 

Convert text to a table 

1. Insert separator characters—such as commas or tabs—to indicate where to divide the text into table 

columns. 

Note: If you have commas in your text, use tabs for your separator characters. 

2. Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns and 2 rows: 

 

1. Select the text that you want to convert, and then click Insert > Table > Convert Text to Table. 

 

2. In the Convert Text to Table box, choose the options you want. 



 

Under Table size, make sure the numbers match the numbers of columns and rows you want. 

Under AutoFit behavior, choose how you want your table to look. Word automatically chooses a 

width for the table columns. If you want a different column width, choose one of these options: 

To do this Choose this option 

Specify a width for all the columns In the Fixed column 

width box, type or select a 

value. 

Resize the columns to fit the width of the text in each 

column 

AutoFit to contents 

Resize the table automatically in case the width of the 

available space changes (for example, web layout or 

landscape orientation) 

AutoFit to window 

Under Separate text at, choose the separator character you used in the text. 

3. Click OK. The text converted to a table should look something like this: 

 

Convert a table to text 

1. Select the rows or table you want to convert to text. 

2. On the Layout tab, in the Data section, click Convert to Text. 



 

3. In the Convert to Text box, under Separate text with, click the separator character you want to use in 

place of the column boundaries. Rows will be separated by paragraph marks. 

4. Click OK. 

 

Q10. Create a file in MS-Word to insert a table in the document. Describe all steps involved in it. 

For a basic table, click Insert > Table and move the cursor over the grid until you highlight the number of 

columns and rows you want. 

 

For a larger table, or to customize a table, select Insert > Table > Insert Table. 

 

Tips:  

 If you already have text separated by tabs, you can quickly convert it to a table. Select Insert > Table, 

and then select Convert Text to Table. 

 To draw your own table, select Insert > Table > Draw Table. 



Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

 

 To create the worksheet, open MS Excel and follow these steps:  

1. Open a new workbook: Click on "New" in the Excel menu. 

2. Enter data: In the cells, type in the following: 

A B C 

ROLL NO NAME MARKS 

1 N1 60 

2 N2 70 

3 N3 80 

4 N4 90 

5 N5 100 

 

3.Save the workbook: Click "File" > "Save As" and give the file the name "book1". Choose the desired 

save location. 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet created in question 

no 10. 

 the sum of the marks using AutoSum in a range of cells (C2:C11) 
 average of the marks in a range of cells (C2:C11) 

 highest marks in a range of cells (C2:C11) 

 minimum marks in a range of cells (C2:C11)
 
 

Calculating the sum, average, maximum, and minimum values of a range of cells in a worksheet. 

1. The sum of the marks using AutoSum in a range of cells (C2:C11) 

 To calculate the sum of marks in the cell range C2:C11 using AutoSum in Excel, you 

would select a cell below the range (e.g., C12), click the AutoSum button (usually on the Home tab), and 

press Enter. Excel will then automatically generate a SUM formula that adds up the values in C2 through 

C11.  

2. Average of the Marks in a Range Of Cells (C2:C11) 



 To calculate the average of the marks in the range C2:C11, use the AVERAGE function 

in Excel or similar spread sheet software. The formula would be =AVERAGE (C2:C11). This function will 

sum the values in cells C2 through C11 and then divide by the number of cells, giving you the average. 

3. Highest Marks in a Range Of Cells (C2:C11)  

 To find the highest marks within the range C2:C11, you can use the MAX function in 

Excel. Enter =MAX (C2:C11) into a cell to display the highest value in that range.  

4. Minimum Marks In a Range Of Cells (C2:C11) 

 To find the minimum marks in the cell range C2:C11 in a spreadsheet like Excel, you can 

use the MIN function. The formula would be =MIN (C2:C11) 

Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 

 To modify the row height of a worksheet 

 To delete rows and columns of a 

worksheet Q13 b) Describe following terms 

in the worksheet 

 Absolute reference and relative reference in formula 

 Cell address 

 

Part a: 

1. 1. Modifying Column Width: 

 Hover the mouse cursor over the column border to the right of the column you want to adjust. The cursor 

should change to a double arrow, .  

 Click and drag the column border to the left or right to increase or decrease the column width.  

 Release the mouse button when the column width is at the desired size.  

2. 2. Modifying Row Height: 

 Hover the mouse cursor over the row border below the row you want to adjust. The cursor should change to a 

double arrow.  

 Click and drag the row border up or down to increase or decrease the row height.  

 Release the mouse button when the row height is at the desired size.  

3. 3. Deleting Rows and Columns: 

 Select the row(s) or column(s) you want to delete.  

 Right-click on the selected rows or columns.  

 Choose "Delete" from the context menu.  

 Confirm the deletion by selecting the appropriate option (e.g., "Delete entire row", "Delete entire 

column") .  

Part b: 



1. 1. Absolute Reference: 

 An absolute reference uses a dollar sign ($) before the column letter and/or row number in a cell address 

within a formula.  

 For example, $A$1 is an absolute reference.  

 When an absolute reference is copied to another cell, it will always refer to cell A1, regardless of where the 

formula is placed, according to Simplilearn.  

2. 2. Relative Reference: 

 A relative reference is the default type of cell reference in Excel.  

 Relative references adjust when copied or filled.  

 For example, if you copy the formula =A1+B1 from cell C1 to C2, it will automatically change 

to =A2+B2 because the references are relative.  

3. 3. Cell Address: 

 A cell address is the unique identifier of a cell in a spreadsheet.  

 It is formed by combining the column letter and the row number (e.g., A1, B2, C10).  

 Cell addresses are used in formulas to specify which cells the formula should calculate.  

 

 

Q14. a) What tools are available to customize our PowerPoint presentation? 

 

PowerPoint offers a range of tools for customization, including themes, slide layouts, text styles, and 

formatting options. You can also utilize features like animations, transitions, and the Designer tool to 

enhance your presentation's visual appeal and interactivity.  

Here's a more detailed breakdown: 

 Themes: Pre-designed color schemes and font styles that provide a cohesive look across your slides.  

 Slide Layouts: Different arrangements of placeholders for text, images, and other content.  

 Text Styles and Formatting: Options for changing fonts, sizes, colors, and effects (e.g., bold, italic, 

underline).  

 Animations: Effects that can be applied to individual objects or entire slides, making your presentation more 

engaging.  

 Transitions: Effects that are applied between slides during the slideshow.  

 Microsoft Designer (formerly AI Design): A feature that automatically suggests design ideas for slides, 

including layouts, images, and SmartArt graphics.  

 Shapes and SmartArt: Tools for creating and adding visual elements, such as diagrams, flowcharts, and 

organizational charts.  

 Backgrounds: The option to insert images, patterns, or solid colors as the backdrop for your slides.  

 Insert: This tab allows you to add various objects, including pictures, charts, graphs, icons, and videos.  



 Slide Master: A master template for all slides in your presentation, allowing you to customize the overall 

appearance and style.  

 Rehearse with Coach: A feature that provides real-time feedback on your speaking pace and content while 

you rehearse your presentation.  

 

By utilizing these tools, you can create a polished and visually appealing presentation that effectively 

communicates your message.  

 

Q14 b) Write the steps for the following action for creation of power point presentation 

 Open a Blank presentation
 Save the presentation as Lab1.pptx

 Add a Title to the first slide: the name of your college
 Type your first name and last name in the Subtitle section
 Add a New Slide which has a Title and Content



Here's how to create a PowerPoint presentation with the specified actions: 

1. Open a Blank Presentation: 

Start PowerPoint, Go to File > New, and Select "Blank Presentation..  

2. Save the Presentation: 

 Go to File > Save As. 

 Choose a location to save the file. 

 Enter "Lab1" as the file name and ensure the file type is ".pptx" (PowerPoint Presentation). 

 Click "Save."  

3. Add a Title and Subtitle:  

 On the first slide, click in the "Add Title" placeholder and type your college's name. 

 Click in the "Add Subtitle" placeholder and type your first and last name.  

4. Add a New Slide: 

 Click the "New Slide" button on the ribbon (usually under the "Home" tab). 

 Choose a layout that includes a title and content, like "Title and Content." 

 Click in the "Add Title" placeholder and type your chosen title for the new slide. 

 Click in the content placeholder and add any text or content you desire.  



Q15. Write steps for creation of a set of PowerPoint slides that demonstrates 

your skill to use the tools of PowerPoint. It should include the following things 

 Title slide &bullet list
 Inserting Excel Sheet
 Clip art and Text
 Slide show effects

 

Adding Bullets in PowerPoint: 

1. Select the text: Highlight the text you want to make into a bulleted list.  

2. Click the Bullets button: On the Home tab, in the Paragraph group, click the Bullets button.  

3. Customize (optional): You can customize the bullets with different styles, colors, or by 

using symbols or images.  

Inserting Excel Sheet 

 

 Using the "Insert" Feature: In the document where you want to insert the spreadsheet (e.g., 

Word), go to "Insert" > "Spreadsheet" > "Existing Excel Spreadsheet". 

 Locate and Select the File: Browse for the Excel file you want to insert and select it. 

 Choose Insertion Method: If you want to insert a chart or table, select "Insert a Chart or 

Table". Otherwise, click "Insert" to embed the spreadsheet 

 Clip art and Text 

 

Inserting Clip Art: 

1. Open your Word document and place your cursor where you want the clip art. 

2. Go to the "Insert" tab. 

3. In the "Illustrations" group, click "Online Pictures" (or "Clip Art" for older versions). 

4. Type a keyword or phrase to describe the clip art you're looking for and press Enter. 

5. Filter the results by "Type" and select "Clip Art". 

6. Select the clip art you want and click "Insert".  

Adding Text: 

1. Type your text directly into the document or insert a text box.  

2. To insert a text box, go to "Insert" > "Text Box" and choose your desired shape.  

3. Select the text and format it with different fonts, sizes, and colors.  

4. You can also add text to clip art by inserting a text box on top of the clip art and then 

formatting the text.  



Slide show effects 

Applying Transitions: 

 Open your presentation: Access the slide show or presentation software.  

 Select the Transitions tab: In most software, you'll find this tab or option to add transitions.  

 Choose an effect: Explore the available options and select the desired transition.  

 Adjust effect options: You may be able to customize the direction, speed, or other 

parameters of the transition.  

 Apply to all slides (optional): Some software allows you to apply the same transition to all 

slides.  

3. Additional Effects: 

 Animations: In addition to slide transitions, you can add animations to individual objects or 

text on a slide.  

 Pan and Zoom: These effects allow you to control how the camera moves within a slide, 

potentially showcasing different areas or details.  

 Sound: Many slideshow software allows you to add sound effects to transitions.  

 

 

 
Part -2 

Q16. What is the difference between Machine Language and High Level Language? 

The main difference between Machine Language (a low-level language) and High-Level 

Language is their level of abstraction and how easily humans can understand and work with 

them. Machine Language is the most basic language a computer understands, using binary 

code (1s and 0s) that directly corresponds to the computer's hardware. High-Level 

Languages, like Python or Java, use English-like syntax and mathematical symbols, 

providing a higher level of abstraction and making them easier for humans to write and 

understand.  

Here's a more detailed breakdown: 

Machine Language: 

 Level of Abstraction: Lowest level, directly understood by the CPU.  

 Syntax: Binary code (1s and 0s).  

 Human Readability: Difficult for humans to read and write.  

 Examples: Not typically written directly by humans, but the final output of compilers or 

interpreters.  

High-Level Language: 



 Level of Abstraction: Higher level, providing more abstraction from the computer's 

hardware. 

 Syntax: Uses English-like statements, mathematical symbols, and more understandable 

structures. 

 Human Readability: Easier for humans to read, write, and debug. 

 Examples: Python, Java, C++, C, and Fortran.  

In essence: Machine language is the "native tongue" of the computer, while high-level 

languages are like human languages that need to be translated into machine language before 

the computer can execute them. High-level languages are generally easier to use because they 

allow programmers to work at a higher conceptual level and avoid dealing with the low-level 

details of the computer's hardware.  

 

Q17. Discuss about different data types of C programming Language. 

C programming language offers three main categories of data types: basic, derived, and user-

defined. Basic types include int for integers, char for characters, float for single-precision 

floating-point numbers, and double for double-precision floating-point numbers. Derived 

types are created from basic types and include arrays, pointers, and functions. User-defined 

types, such as structures, unions, and enumerations, are created by the programmer.  

1. Basic Data Types: 

 int (Integer): Stores whole numbers (positive, negative, or zero) without decimal points.  

 char (Character): Stores single characters, including letters, numbers, and symbols.  

 float (Floating Point): Stores decimal numbers with single precision (limited accuracy).  

 double (Double Precision): Stores decimal numbers with double precision (more accurate 

than float).  

 void: Indicates the absence of a value or a type. It's often used in function declarations when 

the function doesn't return a value.  

2. Derived Data Types: 

 Arrays: 

A collection of similar data types stored in contiguous memory locations. You can define 

arrays of integers, characters, floats, etc.  

 Pointers: 

Variables that store the memory address of another variable. They're used for accessing 

memory directly and are fundamental for working with dynamic memory allocation in C.  

 Structures: 

Allow grouping different data types under a single name. Structures can contain members 

of different data types, allowing for more complex data structures.  



 Unions: Allow storing different data types in the same memory location. This is useful when 

you want to access different parts of the same memory location using different data types.  

 Functions: Blocks of code that perform a specific task. Functions can have different return 

types and take arguments of various data types.  

3. User-Defined Data Types: 

 Structures (struct): As mentioned above, structures allow creating composite data types by 

grouping different data types.  

 Unions (union): Similar to structures, but they share the same memory location for all their 

members.  

 Enumerations (enum): Used to define a set of named integer constants. They are often used to 

represent symbolic values.  

 Typedef: Allows creating aliases for existing data types, making the code more readable. 

 

 Q18. Find the output of the following expressions 

a)  X=20/5*2+30-5  

b) Y=30 – (40/10+6) +10  

c) Z= 40*2/10-2+10 

 

 

a)  X=20/5*2+30-5  

Let's break down the expression step by step: 

X=20/5×2+30−5X = \frac{20}{5} \times 2 + 30 - 5X=520×2+30−5  

1. First, divide 20 by 5: 

20/5=4  

2. Then, multiply the result by 2: 

4×2=8 

3. Add 30: 

8+30=38   

4. Subtract 5: 

38−5=33 



So, the value of X is 33. 

b) Y=30 – (40/10+6) +10  

Let's break down the expression for YY: 

Y=30−(40/10+6)+10Y = 30  

1. First, divide 40 by 10: 

=4  

2. Then, add 6 to the result: 

4+6=104 + 6 = 104+6=10  

3. Now, substitute this back into the expression: 

Y=30−10+10Y = 30 - 10 + 10Y=30−10+10  

4. Subtract 10 from 30: 

30−10=20 

5. Finally, add 10: 

20+10=30  

So, the value of Y is 30. 

 Z= 40*2/10-2+10 

Let's break down the expression for Z: 

Z-40*2/10-2+10 

1. First, multiply 40 by 2: 

40×2=80   

2. Then, divide the result by 10: 

80/10=8  

3. Subtract 2: 

8−2=6 

4. Finally, add 10: 



6+10=16  

So, the value of Z is 16. 

Q19. Describe the syntax of the following statements 

a) If – else statement 

if (condition) { 

 

} 

b) for loop  

for (initialization; condition; update) 

 { 

   

} 

c) while loop  

while (condition) { 

 

} 

d) do-while loop 

do { 

     

} while (condition); 

Q20. Find the output of the following program segments 
a.  
Output 
IMS Ghaziabad 
b.  
Output 
IMS Ghaziabad 
IMS Ghaziabad 
c.  
Output 
 
Largest Number is 100 
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