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Q1: What are the four fundamental parts of computer? Explain it with the 

help of diagram. 

Ans: Weather it is a gaming system or a home PC there are  four main components input, 

CPU, Primary memory, output. 

                                                                

 

 

 

 
 
Central processing unit(CPU):- central processing unit (CPU), also called a central 
processor, main processor or just processor, is the electronic circuitry within a computer 
that 
executes instructions that make up a computer program. The CPU performs basic 
arithmetic, 
logic, controlling, and input/output (I/O) operations specified by the instructions in the 
program. The computer industry used the term "central processing unit" as early as 1955. 
Primary Memory:- Primary memory is computer memory that is accessed directly by the 
CPU. 
This includes several types of memory, such as the processor cache and system ROM. 
However, 
in most cases, primary memory refers to system RAM. 
Output:- An output device is any piece of computer hardware equipment which converts 
information into human-readable form. It can be text, graphics, tactile, audio, and video. 
Some 
of the output devices are Visual Display Units i.e. a Monitor, Printer, Graphic Output 
devices, 
Plotters, Speakers etc. 

Q2: Discuss about the classification of computers based on size and capacity. 

Ans : On the bases of size there are four types of computer.  

1. Micro computer 

2. Mini computer 

3. Mainframe computer 

4. Super computer. 

1. Micro computer :- 

Input  

      

          CPU 

 

Primary memory  

Output 
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A microcomputer is a small, relatively inexpensive computer with a microprocessor as its 

central processing unit (CPU). It includes a microprocessor, memory and minimal 

input/output circuitry mounted on a single printed circuit board (PCB). 

2. Mini computer :- 

  A minicomputer is a type of computer that possesses most of the features and capabilities 

of a large computer but is smaller in physical size. A minicomputer fills the space between 

the mainframe and microcomputer, and is smaller than the former but larger than the latte. 

3. Main frame computer :- 

  A mainframe computer, informally called a mainframe or big iron, is a computer used 

primarily by large organizations for critical applications, bulk data processing such as the 

census and industry and consumer statistics, enterprise resource planning, and large-scale 

transaction processing. 

4. Super computer :- 

 A Supercomputer is  a computer with high level of performance as compared to       a 

general purpose  computer. Use  for weather forecast. They play an important role in the 

field of computational science and are used for wide range of computationally intensive task 

in various field.  

   

Q3: What is the meaning of computer generation? How many Computer 

Generations are defined? What technologies were/are used? 

Ans:  Five different types of computer generation: 

1. first generation  computer (1940 to 1956) 

 The first generation computers were developed by using vacuum tube or                                                                                                                                        
thermionic valve machine. The input of this system was based on punched cards 
and paper tape; however, the output was displayed on printouts. The first generation 
computers worked on binary-coded concept. 

Examples: ENIAC, EDVAC, etc. 

2. Second generation computer (1956 to 1963)  

  The second generation computers were developed by using transistor technology. 
In comparison to the first generation, the size of second generation was smaller and 
take input through punch card and give output through print out. 

3. Third generation computer (1963 to 1971) 

 The third generation computers were developed by using the Integrated Circuit (IC) 
technology In comparison to the computers of the second generation, the size of the 
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computers of the third generation was smaller. The third generation computer 
consumed less power and also generated less heat. The maintenance cost of the 
computers in the third generation was also low. The computer system of the 
computers of the third generation was easier for commercial use. 

4. Fourth generation computer (1972 to 2010) 

 The fourth generation computers were developed by using microprocessor 
technology. By coming to fourth generation, computer became very small in size, it 
became portable. The machine of fourth generation started generating very low 
amount of heat. It is much faster and accuracy became more reliable. The 
production cost reduced to very low in comparison to the previous generation. It 
became available for the common people as well. 

5. Fifth generation computer (2010 till the date) 

 By the time, the computer generation was being categorized on the basis of 

hardware only, but the fifth generation technology also included software. The 

computers of the fifth generation had high capability and large memory capacity. 

Working with computers of this generation was fast and multiple tasks could be 

performed simultaneously. Some of the popular advanced technologies of the fifth 

generation include Artificial intelligence, Quantum computation, Nanotechnology, 

Parallel processing, etc 

Q4: Differentiate between Volatile & Non- Volatile memories.  

ANS- 

SR NO. VOLATILE MEMORY  NON VOLATILE MEMORY  

1. Volatile memory is the type of 
memory in which data is lost as it is 
powered-off. 

Non-volatile memory is the type of memory 
in which data remains stored even if it is 
powered-off. 

2. Contents of Volatile memory are 
stored temporarily. 

Contents of Non-volatile memory are stored 
permanently. 

3. It is faster than non-volatile memory It is slower than volatile memory 

4. RAM (Random Access Memory) is an 
example of volatile memory. 

ROM(Read Only Memory) is an example of 
non-volatile memory 

5. In volatile memory, data can be easily 
transferred in comparison to 
nonvolatile 
memory. 

In non-volatile memory, data cannot be easily 
transferred in comparison to volatile 
memory  
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Q5: Distinguish among system software, application software and open 
source software on the basis of their features? 
ANS- 
System software: - System software is a type of computer program that is designed to run a 
computer's hardware and application programs. If we think of the computer system as a 
layered model, the system software is the interface between the hardware and user 
applications. 
 
Features of system software:- 
System Software is closer to the system. 
Generally written in a low-level language. 
The system software is difficult to design and understand. 
Fast in speed. 
Less interactive. 
Smaller in size. 
Hard to manipulate 
 
Application software:- Application software is a program or group of programs designed for 
end users. Examples of an application include a word processor, a spreadsheet, an 
accounting 
application, a web browser, an email client, a media player, a file viewer, simulators, a 
console 
game or a photo editor. 
 
Features of application software:- 
Perform more specialized tasks like word processing, spreadsheets, email, photo editing, 
etc. 
It needs more storage space as it is bigger in size. 
Easy to design and more interactive for the user. 
Generally written in a high-level language. 
 
Open source software:- Open-source software is a type of computer software in which 
source 
code is released under a license in which the copyright holder grants users the rights to use, 
study, change, and distribute the software to anyone and for any purpose. Open-source 
software may be developed in a collaborative public manner. 
 
Features of open source software:- 
Lesser hardware costs. ... 
High-quality software. ... 
No vendor lock-in ... 
Integrated management. ... 
Simple license management. ... 
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Q6. a) Create a file in MS-word to insert a paragraph about yourself and save 
it with file name“yourself”. Describe all steps involved in it.? 

ANS- 
To open Microsoft Word, click on the Word icon ("W") on the toolbar or desktop. 
An open (and blank) Word document will open on the screen. 
Enter a paragraph about yourself 
When document is finished, click on "File" on the standard toolbar at the top of screen. 
Click on "Save As." 
 

Q6 b) Write steps regarding followings? 
To change the font style 
To change the font size 
To change the font color 
To highlight (in yellow) the line that reads “need to get IMS’s address”. 
 
Steps to change the font style:- 
Go to Format > Font > Font. You can also press and hold. + D to open the Font dialog box. 
Select the font and size you want to use. 
Select Default, and then select yes. 
 
Select OK. 
Steps to change the font size:- 
Select the text or cells with text you want to change. To select all text in a Word document, 
press Ctrl + A. 
On the Home tab, click the font size in the Font Size box. 
Steps to change font color:- 
Select the text that you want to change. 
On the Home tab, in the Font group, choose the arrow next to Font Color, and then select a 
color. 
 

Q7. Create a file in MS-Word for the following document and save it with file 
name ‘msword’.Describe all steps involved in it. 
ANS - 
Steps of create a file in ms word:- 
1. The Start button in the lower-left corner of your screen gives you access to all programs 
on 
your PC—Word included. To start Word: 
choose Start → All Programs → Microsoft Office → Microsoft office word. 
2. And then enter the data 
MS WORD 
MS WORD is a widely used commercial word processor developed by Microsoft. 
Ms Word is application software, which is capable of 
Creating, 
Editing, 
Saving 
Printing and type of document 
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And save this file name "ms word". 

 

Q8. Create a file in MS-word for the following document and save it with file 
name‘equations’. Describe? 
ANS- 
All steps involved in it. 
Choose Insert > Equation and choose the equation you want from the gallery. 
After you insert the equation the Equation Tools Design tab opens with symbols and 
structures 
that can be added to your equation. 
𝑥2 + 𝑦5 = 30 
𝑧3 + 𝑞4 = 50 
𝑎2 + 𝑏8 = 𝑦2 + 𝑦8 

Q9. Create a file in MS-word that convert existing highlight text to table as 
shown below and save it as file name ‘text_to_table’. Describe all steps 
involved in it. 
ANS- 

START MS WORD? 
1. Click on start button and click then run option run dialog box will be appear o screen. 
2. CLICK START PROGRAM-all programs- Microsoft office word 2007. 
Select the text that you want. 
Select the text that you want to convert, and then click Insert > Table > Convert Text to 
Table. 
In the Convert Text to Table box, choose the options you want. 
Under Table size, make sure the numbers match the numbers of columns and rows you 
want. 
Under AutoFit behavior, choose how you want your table to look. Word automatically 
chooses 
a width for the table columns. If you want a different column width, choose one of these 
options. 
Under Separate text at, choose the separator character you used in the text. 
Click OK 

Q10. Create a file in MS-Word to insert a table in the document. Describe all 
steps involved in it. 
ANS- 
Open a blank Word document. 
In the top ribbon, press Insert. 
Click on the Table button. 
Either uses the diagram to select the number of columns and rows you need, or click Insert 
Table and a dialog box will appear where you can specify the number of columns and rows. 
The blank table will now appear on the page. 
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Q11. Create a following worksheet in MS-excel and save it with name 

‘book1’.  

ANS- 

Roll no  Name  Mark 

1 N1 60 

2 N2 70 

3 N3 80 

4 N4 90 

5 N5 40 

6 N6 50 

7 N7 77 

8 N8 44 

9 N9 88 

10 N10 55 

 

Q12. Calculate the following things of a range (C2:C11) of data in the 
worksheet created in 
question no 10. 
ANS- 
The sum of the marks using AutoSum in a range of cells (C2:C11) 
Average of the marks in a range of cells (C2:C11) 
Highest marks in a range of cells (C2:C11) 
Minimum marks in a range of cells (C2:C11) 

Q13 a) Describe various steps involved in the following 
To modify column width of a worksheet 
To modify the row height of a worksheet 
To delete rows and columns of a worksheet 
Ans:- 
Steps of modify column width of worksheet:- 
Select the columns you want to modify. 
Click the Format command on the Home tab. The format drop-down menu appears. 
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Select Column Width. Increasing the column width. 
The Column Width dialog box appears. Enter a specific measurement. 
Click OK. 
Steps of modify column height of a worksheet:- 
Locate and click the Select All button just below the name box to select every cell in 
the worksheet. 
Position the mouse over a row line so the cursor becomes a double arrow. 
Click and drag the mouse to increase or decrease the row height, then release the mouse 
when 
you are satisfied. 
Steps of delete rows and column in worksheet:- 
Right-click in a table cell, row, or column you want to delete. 
On the menu, click Delete Cells. 
To delete one cell, choose Shift cells left or Shift cells up. To delete the row, 
click Delete entire row. To delete the column, click Delete entire column. 

Q13 b) Describe following terms in the worksheet 

Absolute reference and relate 
ANS- 
There are two types of cell references: relative and absolute. Relative and absolute 
references behave differently when copied and filled to other cells. Relative references 
change 
when a formula is copied to another cell. Absolute references, on the other hand, remain 
constant no matter where they are copied. 
Cell address 
Cell address is an alphanumeric value used to identify a specific cell in a spreadsheet. Each 
cell 
reference contains one or more letters followed by a number. The letter or letters identify 
the 
column and the number represents the row. 

Q14. a) What tools are available to customize our PowerPoint presentation? 

The tools are available to customize our PowerPoint presentation are:- 
Persecutor. Persecutor is a tool used by designers to create 3D images on PowerPoint 
presentations. ... 
Pivot Viewer. The Silver light Pivot Viewer is yet another tool frequently used by PowerPoint 
presentation designers. ... 
Autodesk 3DS Max. ... 
Visual Bee PowerPoint Add-In. ... 
Smart Art. ... 
Animations and Transitions. ... 

Q14 b) Write the steps for the following action for creation of power point presentation 

Open a Blank presentation? 
ANS- 
Steps of open a blank a document:- 
If you already have a file open in Word. 
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You can create a new document by clicking File>New. 
You can also use the shortcut Ctrl+N (Commanding for Mac). 
To open a blank document, double-click the blank document option. 
Save the presentation as Lab1.pptx. 
Steps to save the presentation:- 
To save the presentation goes to the file. 
Click on save as option. 
 
And save the presentation giving the name “Lab1.pptx.” 
 
Add a Title to the first slide: the name of your college 
Steps of add a title to the slide:- 
Go to the first slide of presentation. 
Add the title name “abs college”. 
And save it by press “curls”. 
 
Type your first name and last name in the Subtitle section 
Steps of type first name and last name in the subtitle section. 
There are many free software packages (such as Aegis or Subtitle Workshop), that allow you 
to 
type in the subtitles yourself and lock them to a specific time code (e.g. 00:45-00:51). There 
is a 
thing you should keep in mind – adding the subtitles manually is a very time-consuming 
process. Moreover, you will have to dedicate some time to learn the interface and shortcuts 
of 
the software of your choice. 
Add a New Slide which has a Title and Content. 
 
Steps of add a new slide:- 
In the slide preview pane on the left, left-click with your mouse in-between two slides 
where 
you want to insert a slide. 
In the PowerPoint Ribbon, on the Home or Insert tab, click the New Slide option. 
In the drop-down menu that opens, select the type of slide to insert. 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your skill to 

use the tools of PowerPoint. It should include the following things? 
ANS- 
Title slide &bullet list Inserting Excel Sheet 
Clip art and Text 
Slide show effects 
Click the Start button. 
Click All Programs option from the menu. 
Search for Microsoft Office from the sub menu and click it. 
Search for Microsoft PowerPoint from the submenu and click it. 
Go to the “paragraph “icon and select the bullet where you want. 
To insert clip art and text go to the insert tab and click on clip art and choose the picture you 
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want to appear on page. 
And then to slide show effect select the entire slide and go to the “format “and select the 
slide 
show effect .and click on that. 

Q16. What is the difference between Machine Language and High Level Language?  

ANS- 

MACHINE LANGUAGE  HIGH LEVEL LANGUAGE  

1. It is a machine friendly language.  1. It is programmer friendly language  

2. Machine language is high memory 

    efficient.  
2. High level language is less memory efficient  

3. It is tough to understand.  3. It is easy to understand.  

4. It is complex to debug comparatively  4. It is simple to debug.  

5. It is complex to maintain 

   comparatively 
5. It is simple to maintain  

 

Q17. Discuss about different data types of C programming Language? 

ANS - 
To use any language in communication (to write/to speak), we need to understand its 
grammar 
first. In the case of a programming language like C, the scenario is same as in the case of a 
communication language. We need to understand the grammar of C programming language 
first. So here begins:- 
Here are 4 data types in C language. They are:- 
Int – This data type is used to define an integer number (-….-3,-2,-1, 0, 1, 2, 3….). A single 
integer occupies 2 bytes. 
Char – Used to define characters. A single character occupies 1 byte. 
Float – Used to define floating point number(single precision). Occupies 4 bytes. 
Double – Used for double precision floating point numbers (double precision). Occupies 8 
bytes. 

Q18. Find the output of the following expressions? 
ANS - 

X=20/5*2+30-5 
x=30 
Y=30 – (40/10+6) +10 
y=30 
Z= 40*2/10-2+10 
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Z=16 

Q19. Describe the syntax of the following statements? 

ANS - 
If – else statement syntax:- 
if (test expression) 
{ 
// statements to be executed if the test expression is true 
} 
For loopfor 
(initialization Statement; testExpression; updateStatement) 
{ 
// statements inside the body of loop 
} 
While loop 
Syntax 
While (condition test) 
{ 
//Statements to be executed repeatedly 
// Increment (++) or Decrement (--) Operation 
} 
Do-while loop - A do...while loop is similar to a while loop, except the fact that it is 
guaranteed 
to execute at least one time. 
while (testExpression) 
{ 
// statements inside the body of the loop 

 

 

 

 

Q20. Find the output of the following program segments?  

ANS - 

a b c 
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#include <stdio.h> 
int main() 
{ 
int i; 
for (i=1; i<2; i++) 
{ 
printf( "IMS Ghaziabad\n"); 
} 

}  

 

 

 

 

 

 

 

#include <stdio.h> 
int main() 
{ 
int i = 1; 
while ( i <= 2 ) 
{ 
printf( "IMS Ghaziabad\n"); 
i = i + 1; 
} 
} 
# 

 

 

 

 

 

 

 

#include <stdio.h> 
void main() 
{ 
int a = 10, b=100; 
if( a > b ) 
printf( "Largest number is 
%d\n”, a); 
else 
print( "Largest number is 
%d\n”, b); 
}  

 

 

 

 

 

 

 

IMS  

IMS Ghaziabad 

 

 
 
IMS Ghaziabad 
IMS Ghaziabad 

 

 

 

 
 
Compilation failed due to 
following error(s). 
main’s: In function ‘main’: 
main.c:14:9: warning: missing 
terminating " character 
printf( "Largest number is  

 

 

 

 


