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Fundamentals of IT and Programming. 

 

Q1: What are the four fundamental parts of computer? Explain it with the help of 

diagram. 

Ans.  A computer has four main components: the central processing unit or CPU, 

the primary memory, input units and output units.  

Central Processing Unit or CPU: The CPU is referred to as the "brain" of the 

computer by computer scientists because it is where programmes are executed. A 

programme is a set of instructions that informs the computer how to do anything, 

such send a file to the printer, create a browser window, or play music or video. 
The arithmetic unit does all simple mathematical computations; the control units 

interpret the instructions in a computer programme; and the instruction decoding 

unit translates computer programming instructions into machine code. Machine 

code is the common language that all computer components understand. 

Primary Memory: The CPU stores machine code in primary storage or memory 

after converting a set of computer programme instructions into machine code. 

Machine code will be interpreted as data or instructions. The CPU retrieves data 

and instructions from memory, manipulates the data with an instruction, and then 

returns the result and the next set of instructions to memory. 

 

 

 

 

 

 

 

 

Input Units: All of the devices that give information to the computer are input 

units, such as a keyboard, a hard disc, or a networking card. In a similar way that 

your eyes and ears send information to your brain, these devices bring data from 



the "outside world" into your computer. Each input device has its own hardware 

controller, which links to the CPU and primary memory, as well as a set of 

instructions that instructs the CPU on how to use it. 

Output units: Output units are the devices your computer uses to relay 

information to the user, such as a printer, monitors and speakers. For example, 

everything you see on your computer monitor starts as machine code in memory. 

The CPU takes that machine code and converts it into a format required by your 

monitor's hardware. Your monitor's hardware then converts that information into 

different light intensities so that you see words or pictures.  

 

Q2: Discuss about the classification of computers based on size and capacity. 

Ans.       Based on size and capacity, computers are classified as follows:  

Super Computers, Mainframe Computer, Mini Computers, Micro Computers 

Supercomputers: Supercomputers are the most powerful and physically largest 

computers available. These are systems that are designed to process massive 

volumes of data, with the fastest supercomputers capable of performing over a 

trillion computations per second. Supercomputers have tens of thousands of 

processors. Because of their incredible speed, precision, and processing power, 

they are the fastest, most accurate, and most powerful computers available. 

Supercomputers are ideal for tackling difficult issues and completing tasks that 

necessitate a large number of calculations. 

Mainframe Computers: Mainframe computers are massive machines that can 

easily fill a whole room. Thousands of millions of instructions can be processed 

per second. In a mainframe setting, Users connect to the mainframe via the 

mainframe's numerous terminals. Mainframes can support hundreds to thousands 

of users at the same time. Flight scheduling, airline ticketing, reservations, and 

other services are just a few of the things a mainframe can do. 

Minicomputers: Minicomputers are substantially smaller than mainframe 

computers. These machines are also less costly. They're also known as Midrange 

Servers or Midrange Computers. Desktop computers are often larger, more 

powerful, and more expensive. Midrange Small and medium-sized organisations 

typically use PCs as servers. User’s Desktop computers can connect to the server 

across a network. 



Microcomputers: The most common sort of computer is the microcomputer. 

Personal computer is another name for it. A microcomputer, often known as a 

personal computer (PC), is a compact computer system meant to be operated by 

one person one individual at a time. 

 

Q3: What is the meaning of computer generation? How many Computer 

Generations are defined? What technologies were/are used? 

Ans.   The generation of computer means the gap between the developments of the 

computer in terms of the technologies. Each generation of computer is 

characterized by a major technologies development that fundamentally changed the 

way computer operate, resulting in smaller, cheaper, and more powerful, efficient 

and reliable device. 

        Computer generations are classified into five generations: 

 First Generation   

 Second Generation   

 Third Generation  

 Fourth Generation 

 Fifth Generation 

 

First Generation: The original computer systems were huge, took up entire 

rooms, and employed vacuum tubes for circuitry and magnetic drums for memory. 

These computers were extremely expensive to run, and in addition to consuming a 

lot of electricity, they also produced a lot of heat, which was frequently the source 

of failures. To accomplish operations, first-generation computers used machine 

language, which is the lowest-level programming language that computers 

understand, and they could only solve one problem at a time. A new problem 

would take operators days, if not weeks, to set up. Printouts were used to show 

output, which was based on punched cards and paper tape. 

Second Generation: In the second generation of computers, transistors would take 

the place of vacuum tubes. Although the transistor was conceived in 1947 at Bell 

Labs, it was not widely used in computers until the late 1950s. The transistor 

outperformed the vacuum tube, allowing computers to grow smaller, quicker, 

cheaper, more energy-efficient, and more dependable than their predecessors in the 

first generation. Despite the fact that the transistor still generated a lot of heat, 

which caused the computer to malfunction, it was a huge advance over the vacuum 



tube. Punch cards were still used for input and prints on second-generation 

computers. Second-generation computers switched from binary to symbolic (or 

assembly) machine language. 

Third Generation: The third generation of computers was defined by the 

advancement of the integrated circuit. Transistors were downsized and placed on 

silicon chips, known as semiconductors, allowing computers to run faster and more 

efficiently. Instead of punch cards and printouts, users interacted with third-

generation computers via keyboards and monitors, which were connected to an 

operating system that allowed the device to execute multiple programmes at once 

while being controlled by a central software. Computers became accessible to a 

wider audience for the first time since they were smaller and less expensive than 

their predecessors. 

Fourth Generation: Because thousands of integrated circuits were packed onto a 

single silicon chip, the microprocessor ushered in the fourth generation of 

computers. What once took up an entire room might now be contained in the palm 

of one's hand. The Intel 4004 chip, introduced in 1971, combined all of the 

computer's components, from the processor and memory to the input/output 

controllers, on a single chip. As more and more daily devices began to employ 

microprocessors, they migrated out of the sphere of desktop computers and into 

many other aspects of life. As the power of these little computers grew, they could 

be joined together to build networks, leading to the creation of the Internet. The 

fourth generation of computers witnessed the introduction of graphical user 

interfaces (GUIs), the mouse, and handheld devices. 

Fifth Generation: Artificial intelligence-based fifth-generation computer devices 

are still in development, however some applications, such as voice recognition, are 

now in use. Artificial intelligence is becoming a reality because to the usage of 

parallel processing and superconductors. In the coming years, quantum 

computation, molecular and nanotechnology will fundamentally alter the face of 

computers. The goal of fifth-generation computing is to create machines that can 

learn and self-organize and respond to natural language input. 

 

 

 

Q4: Differentiate between Volatile & Non- Volatile memories. 



Ans.  

S.NO Volatile Memory Non-Volatile Memory 

1. 

Volatile memory is the type 

of memory in which data is 

lost as it is powered-off. 

Non-volatile memory is the 

type of memory in which data 

remains stored even if it is 

powered-off. 

2. 

Contents of Volatile memory 

is stored temporarily. 

Contents of Non-volatile 

memory is stored permanently. 

3. 

It is faster than non-volatile 

memory. 

It is slower than volatile 

memory. 

4. 

RAM (Random Access 

Memory) is an example of 

volatile memory. 

ROM (Read Only Memory) is 

an example of non-volatile 

memory. 

5. 

In volatile memory, data can 

be easily transferred in 

comparison to non-volatile 

memory. 

In non-volatile memory, data 

cannot be easily transferred in 

comparison to volatile 

memory. 

6. 

In Volatile memory, process 

can read and write. 

In Non-volatile memory, 

process can only read. 

7. 

Volatile memory generally 

has less storage capacity. 

Non-volatile memory 

generally has more storage 

capacity than volatile memory. 

8. 

In volatile memory, the 

program’s data are stored 

which are currently in process 

by the CPU. 

In non-volatile memory, any 

kind of data which has to be 

saved permanently are stored. 

9. Volatile memory is more Non-volatile memory is less 



S.NO Volatile Memory Non-Volatile Memory 

costly per unit size. costly per unit size. 

10. 

Volatile memory has a huge 

impact on the system’s 

performance. 

Non-volatile memory has a 

huge impact on a system’s 

storage capacity. 

11. 

In volatile memory, processor 

has direct access to data. 

In non-volatile memory, 

processor has no direct access 

to data. 

12. 

Volatile memory chips are 

generally kept on the memory 

slot. 

Non-volatile memory chips are 

embedded on the motherboard. 

 

 

 

 

Q5: Distinguish among system software, application software and open source 

software on the basis of their features. 

Ans.    System Software is a set of programs that control and manage the 

operations of computer hardware. It also helps application programs to execute 

correctly. System Software are designed to control the operation and extend the 

processing functionalities of a computer system. System software makes the 

operation of a computer more fast, effective, and secure. Example: Operating 

system, programming language, Communication software etc. Important feature of 

System Software are: 

 System Software is closer to the system 

 Generally written in a low-level language 

 The system software is difficult to design and understand 

 Fast in speed 

 Less interactive 

 Smaller in size 



 Hard to manipulate 

Application Software is a program that does real work for the user. It is mostly 

created to perform a specific task for a user. Application Software acts as a 

mediator between the end-user and System Software. It is also known as an 

application package. This type of software is written using a high-level 

language like C, Java, VB. Net, etc. It is a user-specific and is designed to meet the 

requirements of the user. Important feature of Application Software are: 

 Perform more specialized tasks like word processing, spreadsheets, email, 

photo editing, etc. 

 It needs more storage space as it is bigger in size 

 Easy to design and more interactive for the user 

 Generally written in a high-level language 

Open-source software (OSS) is a type of computer software in which source code 

is released under a license in which the copyright holder grants users to access, 

change, and improve its source code for their purposes. The main benefits of 

software with a publicly available source code are: 

 Flexibility.  

 Stability.  

 Security and reliability.  

 Easier evaluation.  

 Better support.  

 Possible savings. 

 

 

 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it 

with file name “yourself”. Describe all steps involved in it. 

Ans. 

 Click the Start Button.  

 Click on All Programs.  

 Click Microsoft Office  

 Then click Microsoft Word. 



 Click File tab.  

 Select New. The New Document dialog box appears.  

 Select Blank document and click on create. 

 In a blank document insert a paragraph about myself. 

 Click on File tab.  

 Select Save As – Word Document  

 Select the location where you want to save the document using the drop-

down menu.  

 Enter a name for the file as “Yourself”.  

 Click the Save button. 

 

Q6 b) Write steps regarding following 

 To change the font style  

 To change the font size  

 To change the font colour  

 To highlight (in yellow) the line that reads “need to get IMS’s address”. 

Ans.     To Change the font style: 

 First select the text you want to modify. 

 Click on font style box on the Home tab. The font style drop-down menu 

appears.  

 Move your cursor over the various font styles. 

 Left-click the font sty le you want to use.  

 Then font style will change in the document. 

  To change the font size: 

 First select the text you want to modify.   

 Click on font size box in the Font group on the Home tab.  

 The font size drop-down menu appears.  

 Move your cursor over the various font sizes.  

 Left-click on font size you want to use.  

 Then it will change font size in your document. 

   

 To change the font colour: 
 



 First select the text you want to modify. 

 Click on the font colour box on the Home tab. The font colour menu 

appears. 

 Move your cursor over the various font colours. 

 Left-click the font colour you want to use. 

 Then font colour will change in the document. 

  

To highlight (in yellow) the line that reads “need to get IMS’s address”: 

 Select the text “need to get IMS’s address”. 

 Click on the Text Highlight colour in font group on the Home tab. 

 Various colours will appears. 

 Click on colour yellow. 

 Then highlighted text will change to the colour yellow in the document. 

 

Q7. Create a file in MS-Word for the following document and save it with file 

name ‘MS word’. Describe all steps involved in it. 

MS Word 
MS Word is a widely used commercial word processor developed by Microsoft. MS word is 

application software, which is capable of 

 creating, 

 editing, 

 saving,  and  

 printing any type of document 

Ans.  

 First open Microsoft Word. 

 Click File tab.  

 Select New. The New Document dialog box appears.  

 Select Blank document and click on create. 

 In a blank document type the text provided in the above question. 

 Select the test MS word to change its font size. 

 Click on font size box in the Font group on the Home tab.  

 The font size drop-down menu appears.   

 Left-click on font size and set the font size to 24. 



 To change the font colour of the text ‘MS Word’ and ‘saving’ select the text. 

 Click on the font colour box on the Home tab. The font colour menu 

appears. 

 Left-click the font colour red. 

 Then font colour will change for both in the document. 

 To underline the text ‘word processor’ select the text first. 

 Click the Underline command in the Font group on the Home tab. 

 Then text will change in the document. 

 To change the text ‘MS word’ to italics first select the text. 

 Click the Italic command in the Font group on the Home tab. 

 Then text will change in the document 

 To add bullets to the selected list first select the list.  

 Left-click the bullet or numbering style you want to use. It will appear in the 

document. 

 

 To add strikethrough to the selected text. 

 Click on strikethrough in font group on the Home tab. 

 Then it will cross the selected text ‘and’ in the document then 

 Click on File tab.  

 Select Save As – Word Document  

 Select the location where you want to save the document using the drop-

down menu.  

 Enter a name for the file as “ms_word”.  

 Click the Save button. 

 

 

   

Q8. Create a file in MS-word for the following document and save it with file 

name ‘equations’. Describe all steps involved in it. 

Equations: 

X2 + Y5 = 30 

Z
3 
 + Q

4
 = 50 



A2 + B
8
 = X2 + Y

8
 

Ans.  For the first equation  

 First type the whole equation then 

 Select the text you want to modify as a subscript which are the number 2 and 

5  

 Click on the subscript command on the Home tab 

 Then it will change the text as subscript in the document 

For The second Equation  

 First type the whole equation then 

 Select the text you want to modify as a superscript which are the numbers 3 

and 4  

 Click on the superscript command on the Home tab 

 Then it will change the text as superscript in the document 

For the Third Equation 

 First type the whole equation then 

 Select the text you want to modify as a subscript which are the numbers 2 

and 2 

 Click on the subscript command on the Home tab 

 Then it will change the text as subscript in the document 

 Then for the superscript select the numbers 8 and 8 then 

 Click on the superscript command on the Home tab 

 Then it will change the text as superscript in the document 

To finally save the file: 

 Click on File tab.  

 Select Save As – Word Document  

 Select the location where you want to save the document using the drop-

down menu.  

 Enter a name for the file as “equations”.  

 Click the Save button. 

 

 



Q9. Create a file in MS-word that convert existing highlight text to table as shown 

below and save it as file name ‘text_to_table’. Describe all steps involved in it. 

Select the text you want to convert. 

Select the Insert tab. 

Click on Table command. A dialog box appears. 

Click on Convert Text to Table, a new dialog box appears. 

Here set number of columns. 

Click on OK Finally Selected text convert in a table 

 

 

 

 

 

Ans.    

 Open Microsoft Word. 

 Click File tab.  

 Select New. The New Document dialog box appears.  

 Select Blank document and click on create. 

 In a blank document insert the text as given in the question. 

 Select the text you want to convert. 

 Select the Insert tab. 

 Click on Table command. A dialog box appears. 

 Click on Convert Text to Table, a new dialog box appears. 

 Here set number of columns to 2. 

 Click on OK Finally Selected text is converted to a table. 

 Then Click on File tab.  

 Select Save As – Word Document  

 Select the location where you want to save the document using the drop-

down menu.  

 Enter a name for the file as “text_to_table”.  

 Click the Save button. 

 

 

Select the text you want to 
convert. 

Select the Insert tab. 

Click on Table command. A dialog 
box appears. 

Click on Convert Text to Table, a 
new dialog box appears. 

Here set number of columns. Click on OK Finally Selected text 
convert in a table 



Q10. Create a file in MS-Word to insert a table in the document. Describe all steps 

involved in it. 

Ans.  

 Open Microsoft Word. 

 Click File tab.  

 Select New. The New Document dialog box appears.  

 Select Blank document and click on create. 

 Place your insertion point in the document where you want to insert table 

 Select the Insert tab. 

 Click the Table command. 

 Drag your mouse over the diagram squares to select the number of columns 

and rows in the table. 

 Left-click your mouse, and the table appears in the document. 

 Enter text into the table. 

 Then Click on File tab.  

 Select Save As – Word Document  

 Select the location where you want to save the document using the drop-

down menu.  

 Enter a name for the file.  

 Click the Save button. 

 

 

Q11. Create a following worksheet in MS-excel and save it with name ‘book1’. 

Ans.   

 

 

 

Q12. Calculate the following things of a range (C2:C11) of data in the worksheet 

created in question no 11.  

 The sum of the marks using AutoSum in a range of cells (C2:C11) 

 Average of the marks in a range of cells (C2:C11) 

 Highest marks in a range of cells (C2:C11) 



 Minimum marks in a range of cells (C2:C11) 

Ans.  

The sum of the marks using AutoSum in a range of cells (C2:C11) is = 654 

Average of the marks in a range of cells (C2:C11) is = 65.4 

Highest marks in a range of cells (C2:C11) is = 90 

Minimum marks in a range of cells (C2:C11) is = 40 

 

 

 

Q13 a) Describe various steps involved in the following 

 To modify column width of a worksheet 

 To modify the row height of a worksheet 

 To delete rows and columns of a worksheet 

Ans.  To modify column width of a worksheet: 

 Position the cursor over the column line in the column heading  

 A double arrow will appear 

 Left-click the mouse, then drag the cursor to the right to increase the column 

width or to the left to decrease the column width 

 Release the mouse button.  

Or 

  Left-click the column heading of a column you want to modify.  

 The entire column will appear highlighted. 

 Click the Format command in the Cells group on the Home tab. A menu will 

appear 

 Select Column Width to enter a specific column measurement 

 Select AutoFit Column Width to adjust the column so all the text will fit. 

 

To modify the row height of a worksheet: 

 Position the cursor over the row line you want to modify, and a double arrow 

will appear 



 Left-click the mouse, then drag the cursor upward to decrease the row height 

or downward to increase the row height 

 Release the mouse button. 

Or 

 Click the Format command in the Cells group on the Home tab. A menu will 

appear 

 Select Row Height to enter a specific row measurement 

 Select AutoFit Row Height to adjust the row so all of the text will fit. 

 

To delete rows and columns of a worksheet: 

 Select the row or column you want to delete 

 Click the Delete command in the Cells group on the Home tab 

 Selected column or row deleted 

 

Q13 b) Describe following terms in the worksheet 

 Absolute reference and relative reference in formula 

 Cell address 

Ans.   Absolute reference is the cell reference in which the row and column are 

made constant by adding the dollar ($) sign before the column name and row 

number. The absolute reference does not change as you copy the formula from 

one cell to other. If either the row or the column is made constant then it is known 

as a mixed reference. You can also press the F4 key to make any cell reference 

constant. $A$1, $B$3 are examples of absolute cell reference. For example, we 

want to multiply the sum of marks of two subjects, entered in column A and 

column B, with the percentage entered in cell C2 and display the result in column 

D. Here, we will use absolute reference so that the address of cell C2 remains 

constant and does not change with the relative position of column and rows. 

Relative reference is the default cell reference in Excel. It is simply the 

combination of column name and row number without any dollar ($) sign. When 

you copy the formula from one cell to another the relative cell address changes 

depending on the relative position of column and row. C1, D2, E4, etc. are 

examples of relative cell references. Relative references are used when we want 



to perform a similar operation on multiple cells and the formula must change 

according to the relative address of column and row. 

For example, we want to add the marks of two subjects entered in column A and 

column B and display the result in column C. Here, we will use relative reference 

so that the same rows of column’s A and B are added. 

 

Cell Address or Cell reference is the address or name of a cell or a range of 

cells. It is the combination of column name and row number. It helps the software 

to identify the cell from where the data/value is to be used in the formula. We can 

reference the cell of other worksheets and also of other programs. 

There are two types of cell references in Excel:   

 Relative reference 

 Absolute reference 

 

 

 

Q14. a) What tools are available to customize our PowerPoint presentation? 

Ans.    Some of the important tools that are available in PowerPoint presentation 

are discussed as follows: 

1. Home Tab: Firstly in PowerPoint there are slides. Users need to add content to 

them to make a presentation. From the home menu users can add new slides, 

decide their sequence, layout, design and other word processing functions like font 

change, size change, etc. PowerPoint layout is used to change the layout of the 

current slide. Multiple options and layouts are available based on which a 

presentation can be created. This option is available under the “Home” section and 

one can select from the multiple layout options provided. 

2. Insert: From the Insert menu the user can add media like pictures, symbols, 

audio, video, header, footer, shapes, etc. to the slides to enhance the users 

presentation. 

3. Design: The design menu offers the user with ready-made templates and 

background designs for slides that make the presentation look very attractive. 

Although there are existing design templates available, in case someone wants to 

add some new texture or colour, the option to customise the design is also 

available. Apart from this, slide designs can also be downloaded online. 



4. Transition: A slide transition is the visual effect that occurs when you move 

from one slide to the next during a presentation. You can control the speed, add 

sound, and customize the look of transition effects. There are a variety of transition 

slides available on PowerPoint that a user can add to his slides to make them more 

interactive to his audience. 

5. Animations: During the slide show, the slides appear on the screen one after the 

other. In case, one wants to add some animations to the way in which a slide 

presents itself, they can refer to the “Animations” category. Transitions and 

Animations are the unique functions of PowerPoint. These menus offer different 

options in which the text appears on the slides and takes transition from one slide 

to another. 

6. Slideshow: From the slideshow menu the users can view the final form of the 

slideshow. Users can start the slideshow from the first slide or the slide that users 

are editing. They can also set display time for each slide from the slide show menu. 

7. Review: The various tools that one can use under this tab are; Spelling, research, 

thesaurus, translate, language. The research button aids in online research in books 

and internet resources about a subject or topic you are working on. Thesaurus tool 

lists words arranged together according to the similarity of meaning. By using this 

one can easily find synonyms for relative words in the content. Translate language 

is employed to change the English language words to another language. 

8. View: In the View tab the user can have a normal view of the presentation. This 

is also called the default view. It consists of slides where one can add content to the 

presentation. 

 

 

 

Q14 b) Write the steps for the following action for creation of power point 

presentation 

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 Add a Title to the first slide: the name of your college 

 Type your first name and last name in the Subtitle section 

 Add a New Slide which has a Title and Content 



Ans.   

To open a Blank presentation: 

 Click the Start Button.  

 Click on All Programs.  

 Click Microsoft Office  

 Then click on PowerPoint. 

 The New Presentation window appears 

 Select New. 

 In the left side of the New Presentation window, click Installed Templates. 

 Click a template to select it. 

 Click Create 

To save the presentation as Lab1.pptx: 

 Click the Microsoft Office button. 

 Select Save As.  

 The Save As dialog box appears. 

 Select the location where you want to save the presentation using the drop-

down menu. 

 Enter a name for the document as “Lab1.pptx”  

 Click the Save button 

To add a Title to the first slide: the name of your college: 

 Click on the Title 

 Type the name of my college “St.Edmunds College” 

 If necessary, press [Return] or [Enter] to move to a new line 

 Click anywhere on the slide outside of the placeholder to deselect it. 

To type your first name and last name in the Subtitle section: 

 Click on the Subtitle 

 Type your name and last name “Longmilan Challam” 

 If necessary, press [Return] or [Enter] to move to a new line 

 Click anywhere on the slide outside of the placeholder to deselect it. 

To add a New Slide which has a Title and Content: 



 On the Home tab, click the New Slide button in the Slides group. 

PowerPoint adds a blank slide to your presentation or 

 Press Ctrl+M. And again, PowerPoint adds a blank slide or  

 Right-click in the Slides or Outline tab on the left and then choose New 

Slide. And again, PowerPoint adds a blank slide. 

 

 

 

Q15. Write steps for creation of a set of PowerPoint slides that demonstrates your 

skill to use the tools of PowerPoint. It should include the following things 

 Title slide &bullet list  

 Inserting Excel Sheet 

 Clip art and Text 

 Slide show effects 

Ans.  First of all we need to create a blank presentation by opening Microsoft 

Office and clicking on PowerPoint. Then the New Presentation window appears 

and Select New. We then choose a template and click on a template. Then we 

Click Create. 

 Title slide &bullet list: 

 Click on the Title 

 Type the text we want in the text box. 

 If necessary, press [Return] or [Enter] to move to a new line 

 Click anywhere on the slide outside of the placeholder to deselect it. 

 Select the text you want to format as a list.  

 Click the Bullets or Numbering commands on the Home tab. 

 Left-click the bullet or numbering style you want to use. It will appear in the 

document.  

 Position your cursor at the end of a list item, and press the Enter key to add 

an item to the list. 

 

Inserting Excel Sheet: 



 In PowerPoint, select the Insert tab & Click the Insert tab. 

 Click the Object command in the Text group.  

 A dialog box will appear. 

 Locate and select the desired Excel file, then click Insert. 

Clip art and Text: 

 Please click on the Title, Subtitle, or Text placeholder. 

 Type the text as you want. 

 If necessary, press [Return] or [Enter] to move to a new line. 

 Click anywhere on the slide outside of the placeholder to deselect it. 

 Clip Art can be added from the insert tab. 

Slide show effects: 

 To add slide show effects we need multiple slides and to do that on the 

Home tab, click the New Slide button in the Slides group. PowerPoint adds a 

blank slide to your presentation. 

 Click on Animation tab or Transition tab. 

 A variety of effects will appear  

 Choose one of the effects and select apply  

 The selected effect will be applied to the slideshow. 

 

 

 

 

 

 

 

 

 

 

 



 

Part -2  

Q16. What is the difference between Machine Language and High Level 

Language? 

Ans. Machine Language: A computer programming language consisting of binary 

instructions which a computer can respond to directly. Sometimes it is referred to 

as machine code or object code, machine language is a collection of binary digits 

or bits that the computer reads and interprets. A computer cannot directly 

understand the programming languages used to create computer programs, so the 

program code must be compiled. Example: 01001000, 01100101, 01101100, 

01101100 etc. 

Advantage:  

 This language makes fast and efficient use of the computer. 

 It requires no translator to translate the code. It is directly understood by the 

computer.  

Disadvantage: 

 All memory addresses have to be remembered. 

 All operation codes have to be remembered. 

High-level language: A high-level language is any programming language that 

enables development of a program in a much more user-friendly programming 

context. This language is a programming language with strong abstraction about 

the details of the computer in contrast to low-level programming language 

(Assembly Language). Ex: C, C++, Java High level languages are grouped in two 

categories based on execution model – compiled or interpreted languages. 

Compiler and interpreter are used to convert the high level language into machine 

level language. The program written in high level language is known as source 

program and the corresponding machine level language program is called as object 

program. Both compiler and interpreter perform the same task but there working is 

different. Compiler read the program at-a-time and searches the error and lists 

them. If the program is error free then it is converted into object program. When 

program size is large then compiler is preferred. Whereas interpreter read only one 

line of the source code and convert it to object code.  

Advantages  



 High level languages are programmer friendly. They are easy to write, debug 

and maintain.  

 It provide higher level of abstraction from machine languages.  

 It is machine independent language.  

 Easy to learn and less error prone, easy to find and debug errors.  

 High level programming results in better programming productivity.  

Disadvantages: 

 It takes additional translation times to translate the source to machine code.  

 High level programs are comparatively slower than low level programs.  

 Compared to low level programs, they are generally less memory efficient.  

 Cannot communicate directly with the hardware. 

 

 

Q17. Discuss about different data types of C programming Language. 

Ans. The different data types of C Programming are: 

 

Char: The most basic data type in C. It stores a single character and requires a 

single byte of memory in almost all compilers. The char data type is 1 byte in size 

or 8 bits. This is mostly the same and is not affected by the processor or the 

compiler used. 

Int: As the name suggests, an int variable is used to store an integer. There is a 

very easy way to remember the size for int data type. The size of int data type is 

usually equal to the word length of the execution environment of the program. In 

simpler words, for a 16-bit environment, int is 16 bits or 2 bytes, and for a 32-bit 

environment, int is 32 bits or 4 bytes. 

Float: It is used to store decimal numbers (numbers with floating point value) 

with single precision. The float data type is 4 bytes or 32 bits in size. It is a single-

precision data type that is used to hold decimal values. It is used for storing large 

values 

Double: It is used to store decimal numbers (numbers with floating point value) 

with double precision. The double data type is 8 bytes or 64 bits in size. It can 

store values that are double the size of what a float data type can store, hence it is 

called double. In the 64 bits, 1 bit is for sign representation, 11 bits for 



the exponent, and the rest 52 bits are used for the mantissa. The double data type 

can hold approximately 15 to 17 digits, before the decimal and after the decimal. 

 

 

Q18. Find the output of the following expressions  

a) X=20/5*2+30-5     b) Y=30 – (40/10+6) +10     c) Z= 40*2/10-2+10 

Ans.    a) X=20/5*2+30-5            b) Y=30 – (40/10+6) +10 

                  =4*2+30-5                         =30 – (4+6) +10       

                  =8+30-5                             =30 – 10 + 10 

                  =38-5                                 =20 + 10 

                  =33                                    = 30 

              

                c) Z= 40*2/10 – 2+10 

                    =80/10 – 2 +10 

                    =8 – 2 + 10 

                    =6 + 10 

                    =16    

 

 

 

Q19. Describe the syntax of the following statements a) If – else statement b) for 

loop c) while loop d) do-while loop 

Ans. 

a) If – else statement:   

if (expression)     

{  



Block of statements;  

}  

else  

{  

Block of statements;  

} 

 

b) for loop: 

for ( expression1; expression2; expression3) 

{  

Single statement  

or Block of statements;  

} 

 

c) while loop: 

while ( expression ) 

{  

Single statement  

or  

Block of statements;  

}  

 

d) do-while loop: 

do  

{  

Single statement  

or  



Block of statements;  

}while(expression); 

 

 

 

 

 

 

Q20. Find the output of the following program segments 

Ans.  

a) 

#include <stdio.h>  

int main()  

{  

int i;  

  for (i =1; i<2; i++) 

  { 

    printf (“IMS Ghaziabad\n”); 

   }  

{  

Output:  

IMS Ghaziabad 

IMS Ghaziabad 

 

b) 

#include<stdio.h>  

int main()  

{  

  int i = 1;  

   while ( i <= 2 )   

   {  



     printf("IMS Ghaziabad\n");  

     i = i + 1;  

    }  

} 

Output:  

IMS Ghaziabad 

IMS Ghaziabad 

 

 

 

c) 

#include <stdio.h> 

void main()  

{ 

   int a = 10, b=100;   

     if (a > b)  

       printf ("Largest number is %d\n”, a);  

       else  

       printf ("Largest number is %d\n”, b); 

} 

Output: 

Largest number is 100 

 

 

 

 

 



Greetings, my name is Mebaaibor Ryngksai. I am 24 years old and recently 

completed my geography degree at St. Edmunds College in Shillong, 

Meghalaya. IGNOU is where I am now pursuing my master's degree in 

public administration.In my spare time, I enjoy watching psychological 

thriller and fantasy films and playing chess. 



MS Word is a widely used commercial word processor developed by Microsoft. MS word is 

application software, which is capable of 

 creating, 

 editing, 

 saving,  and  

 printing any type of document 

 



X2 + Y5 = 30 

Z
3 
 + Q

4
 = 50 

A2 + B
8
 = X2 + Y

8
 

 



 

 

 

 

 

 

Select the text you want to convert. Select the Insert tab. 

Click on Table command. A dialog box appears. Click on Convert Text to Table, a new dialog box 
appears. 

Here set number of columns. Click on OK Finally Selected text convert in a table 



Roll No Name Marks

1 n1 60

2 n2 70

3 n3 80

4 n4 90

5 n5 40

6 n6 50

7 n7 77

8 n8 44

9 n9 88

10 n10 55

Sum 654

Average 65.4

Highest 90

Minimum 40


