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Q1: What are the four fundamental parts of computer? 
Explain it with the help of diagram. 

computer is any machine that can be programmed to carry out a set 
of algorithms and arithmetic instructions.  

There are five basic components which include: 

1. Input Unit 
2. Output Unit 
3. Memory Unit 
4. Control Unit 
5. Arithmetical and Logical Unit 

 

 Input Unit 
A computer will only respond when a command is given to the device. These commands can be 
given using the input unit or the input devices.  

For example: Using a keyboard we can type things on a Notepad and the computer processes 
the entered data and then displays the output of the same of the screen. 

 Output Unit 
When we command a computer to perform a task, it reverts for the action performed and gives 
us a result. This result is called output. There are various output devices connected to the 



computer. The most basic of which is a monitor. Whatever we write using a keyboard or click 
using a mouse, is all displayed on the monitor. 

Thus, the output unit gives us the final result once the entire processing is done within the 
mechanism of a device. 

For example: when we visit an ATM, we enter our details like language, pin, amount to be 
withdrawn, etc. and then the final money which the cash dispenser releases is our outcome. In 
this case, the cash dispenser acts as an output unit.  

 Memory Unit 
When we enter the data into the computer using an input device, the entered information 
immediately gets saved in the memory unit of the Central Processing Unit (CPU). Because of the 
presence of some existing programming, the Memory Unit transmits the data further to the other 
parts of the CPU. 

Similarly, when the output of our command is processed by the computer, it is saved in the 
memory unit before giving the output to the user. 

 Control Unit 
This is the core unit which manages the entire functioning of the computer device. It is one of the 
most essential components of the computer system.  

The Control Unit collects the data entered using the input unit, leads it on for processing and 
once that is done, receives the output and presents it to the user. It can be said to the centre of 
all processing actions taking place inside a computer device.  

 Arithmetic & Logical Unit 
As the name suggests, all the mathematical calculations or arithmetic operations are performed 
in the Arithmetic and Logical Unit of the CPU.  

It can also perform actions like a comparison of data and decision-making actions. The ALU 
comprises circuits using which addition, subtraction, multiplication, division and other numerical 
based calculations can be performed 

 

Q2: Discuss about the classification of computers based on size and 
capacity. 

Classifications of Computers System :- 

 

Computers on the Basis of Size and Capacity 



1. Super Computer 
2. Mainframe Computer 
3. Mini Computer 
4. Micro Computer 
1. SuperComputer 
A Supercomputer is the very fastest and powerful, and expensive type of computer for 
processing data. Supercomputers’ size and storage capacity are also huge (can occupy 
huge premises) designed to process vast amounts of data in a short time with high 
productivity. 
These are specially made to perform multi-specific tasks. Therefore, many CPUs work in 
parallel order on these supercomputers. This function of a Supercomputer is called 
Multiprocessing or Parallel Processing. A supercomputer’s design is complicated, like it 
can be heterogeneous, combining computers of different architectures, is significantly 
surpassed most existing personal computers. This made this machine an ultra-high-
performance supercomputer. 

Applications:  The uses of supercomputers are dedicated to – 
 In research and study of energy and nuclear weapons and designing the 

aircraft, airplanes, and flight simulators. 
 Climate research and Weather Forecasting and Prediction of Natural 

Disasters. 
 Spaceship and Satellite Launching. 
 Used in scientific research laboratories. 
 Used in Chemical and Biological research and for highly calculation 

complex tasks. 
Examples: IBM Roadburner, IBM Blue Gene, Intel ASI Red. PARAM-1000, and CRAY-XMP-
14. 
2. Mainframe Computer 
Mainframe computers are multi-programming, high-performance computers, and multi-
user, which means they can handle the workload of more than 100 users at a time on the 
computer. 

The storage capacity of the mainframe is enormous, with a high-speed data process as 
well. As well as handling hundreds of input and output devices at a time. 

The mainframe is a highly efficient computer capable of simultaneously 
solving complex calculations and continuously for a long time. These computers have 
several microprocessors that have the ability to function the data at too high 
performance and speed. 

The mainframe is ahead of our conventional modern Personal computers in almost 
every metric. The possibility of their “hot” replacement in the mainframe computer 
ensures continuity of operation. And the standard amount of processor utilization 
effortlessly exceeds 85% of the total power. 

Applications: Uses of Mainframe Computer – 



Mainframe computers are mainly used by departmental and commercial organizations 
like Banks, Companies, Scientific research centers, and governmental departments like 
railways. These computers can work for 24 hours. Hundreds of users can work on these 
computations simultaneously. 

Examples: IBM Es000 series, ICL39 Series, and CDC 6600. 

3. Mini Computer 
Minicomputer is a digital and multi-user computer system with the connection of more 
than one CPU. Thus, many people can work on these computers simultaneously instead 
of a single person. Also, it can process with other accessories like a printer, plotter, etc. 

Applications: The uses of Minicomputers – 

The minicomputers are used as real-time applications in Industries, bookings, and 
Research Centres. Banks also use minicomputers for preparing payroll for employees’ 
salaries, records, tracking of financial accounts, etc. As well as in the field of Higher 
Education and Engineering. 
Examples: PDP 11 and IBM (8000 Series). 
 
4. Micro Computer 
Today we are using many computers at home is also the most common microcomputer. 
With this invention of the microprocessors in the year 1970, it became possible to use 
computers for people personally at a low cost and reasonable price known as 
Digital Personal Computer. The design of microcomputers is minimal in size and 
storage capacity. These computers consist of many parts like Input and Output devices, 
Software, operating systems, networks, and Servers all these need to connect to form a 
complete Personal Digital Computer. 

Applications: The uses of MicroComputer – 
PC is being widely used in many fields like home, office, data collection, business, 
education, entertainment, publishing, etc. 
It keeps the details and prepares letters for correspondence in small businesses, 
creating bills, accounting, word processing, and operation of the filing systems in a large 
company. 

Examples: Desktops, tablets, smartphones, and Laptops. 

 

Generation in computer terminology is a change in technology a computer is/was 
being used. Initially, the generation term was used to distinguish between varying 
hardware technologies. Nowadays, generation includes both hardware and software, 
which together make up an entire computer system 

 



Q3: what is the meaning of computer generation? How many 
Computer Generations are 

defined? What technologies were/are used? 

First generation (1940 - 1956) 

 

The first generation of computers used vacuum tubes as a major 

piece of technology. Vacuum tubes were widely used in computers 

from 1940 through 1956. Vacuum tubes were larger components 

and resulted in first-generation computers being quite large in size, 

taking up a lot of space in a room. Some of the first-generation 

computers took up an entire room. 

The ENIAC is a great example of a first-generation computer. It 

consisted of nearly 20,000 vacuum tubes, 10,000 capacitors, and 

70,000 resistors. It weighed over 30 tons and took up a lot of 

space, requiring a large room to house it. Other examples of first-

generation computers include the EDSAC, IBM 701, and Manchester 

Mark 1. 

Second generation (1956 - 1963) 

 



The second generation of computers saw the use 

of transistors instead of vacuum tubes. Transistors were widely used 

in computers from 1956 to 1963. Transistors were smaller than 

vacuum tubes and allowed computers to be smaller in size, faster in 

speed, and cheaper to build. 

The first computer to use transistors was the TX-0 and was 

introduced in 1956. Other computers that used transistors include 

the IBM 7070, Philco Transac S-1000, and RCA 501. 

Third generation (1964 - 1971) 

 

The third generation of computers introduced the use 

of IC (integrated circuits) in computers. Using IC's in computers 

helped reduce the size of computers even more than second-

generation computers, and also made them faster. 

Nearly all computers since the mid to late 1960s have utilized IC's. 

While the third generation is considered by many people to have 

spanned from 1964 to 1971, IC's are still used in computers today. 

Over 45 years later, today's computers have deep roots going back 

to the third generation. 

Fourth generation (1972 - 2010) 



 

The fourth generation of computers took advantage of the invention 

of the microprocessor, more commonly known as a CPU. 

Microprocessors, with integrated circuits, helped make it possible for 

computers to fit easily on a desk and for the introduction of the 

laptop. 

Some of the earliest computers to use a microprocessor include 

the Altair 8800, IBM 5100, and Micral. Today's computers still use a 

microprocessor, despite the fourth generation being considered to 

have ended in 2010. 

Fifth generation (2010 to present) 

 

The fifth generation of computers is beginning to use AI (artificial 

intelligence), an exciting technology with many potential 

applications around the world. Leaps have been made in AI 

technology and computers, but there is still room for much 

improvement. 

One of the more well-known examples of AI in computers is IBM's 

Watson, which was featured on the TV show Jeopardy as a 

contestant. Other better-known examples include Apple's Siri on the 

iPhone and Microsoft's Cortana on Windows 8 and Windows 10 



computers. The Google search engine also utilizes AI to process 

user searches. 

Sixth generation (future generations) 

As of 2021, most still consider us to be in the fifth generation as AI 

continues to be developed. One possible contender for a future sixth 

generation is the quantum computer. However, until quantum 

computing becomes more developed and widely used, it's still only a 

promising technology. 

 

Q4: Differentiate between Volatile & Non- Volatile memories. 

1. 
Volatile memory is the type of memory in 
which data is lost as it is powered-off. 

Non-volatile memory is the type of memory 
in which data remains stored even if it is 
powered-off. 

2. 
Contents of Volatile memory is stored 
temporarily. 

Contents of Non-volatile memory is stored 
permanently. 

3. It is faster than non-volatile memory. It is slower than volatile memory. 

4. 
RAM(Random Access Memory) is an 
example of volatile memory. 

ROM(Read Only Memory) is an example of 
non-volatile memory. 

5. 

In volatile memory, data can be easily 
transferred in comparison to non-volatile 
memory. 

In non-volatile memory, data can not be 
easily transferred in comparison to volatile 
memory. 

6. 
In Volatile memory, process can read and 
write. 

In Non-volatile memory, process can only 
read. 



7. 
Volatile memory generally has less 
storage capacity. 

Non-volatile memory generally has more 
storage capacity than volatile memory. 

8. 

In volatile memory, the program’s data 
are stored which are currently in process 
by the CPU. 

In non-volatile memory, any kind of data 
which has to be saved permanently are 
stored. 

9. 
Volatile memory is more costly per unit 
size. 

Non-volatile memory is less costly per unit 
size. 

10. 
Volatile memory has a huge impact on 
the system’s performance. 

Non-volatile memory has a huge impact on 
a system’s storage capacity. 

Q5: Distinguish among system software, application software and 
open source software on the basis of their features. 

System Software? 

System software provides an interface between the system hardware and the user. It lets 
the system understand the command that the user inputs. We can also say that the 
system software serves as an interface between the hardware in a system and application 
software. It is also called as general purpose software. The end user usually does not 
directly interact with the system software. The user only gets to interact with the GUI that 
has been created by the system software. 

Application Software? 

We can define an application software as software written on a high-level language such 
as Java, C++, .net and VB for instance. This software is meant to meet some specific needs 
of the user. Some of the kinds of application software are designing software, a 
computing software, and an editing software. There is a specific purpose behind every 
application software. 

Open source software   is software with source code that anyone can inspect, modify, and 
enhance. 

"Source code" is the part of software that most computer users don't ever see; it's the 
code computer programmers can manipulate to change how a piece of software—a 
"program" or "application"—works. Programmers who have access to a computer 
program's source code can improve that program by adding features to it or fixing parts 
that don't always work correctly. 

 



Examples and conclusion 
 
System software and application software together make a system useful to the end user. 
A system cannot run without system software. In other words, it is compulsory for making 
the system run. Application software is essential to perform specific tasks. They help 
achieve versatile kinds of functions on a system thus helping to customize a system for the 
specific requirements and situations of the user. 

Q6. a) Create a file in MS-word to insert a paragraph about yourself and save it with 
file name 

“yourself”. Describe all steps involved in it. 

Step 1: Open Ms word on your system. 

Step 2: Click on the new file when you open the word file when the dialog 
box appear. 

Step 3: Once this click on Blank doc under the recent section, it will get in 
bold or highlighted by default. 

Step 4: Click on the create A new blank doc will open. 

Step 5: Once it is opened you can write anything you want in the doc for 
yourself. 

Step 6: You can also edit the text you have written as you can change the 
background color ,or the text and many other things in the docs. 

Q6 b) Write steps regarding followings 

A]. To change the font style 

B]. To change the font size 

C].  To change the font color 

D]. To highlight (in yellow) the line that reads “need to get 
IMS’s address”. 

 

A]   How to Change Font Style in MS Word 

1. Select the text you want to modify. 

2. Select the Home tab and locate the Font group. 

3. Click the drop-down arrow next to font style box. 



4. Font style menu appearsS 

5. With a left click select the desired font style. 

B]. How to change the font size on Windows 10 

1. Click on the Windows icon and type "Settings" and click on the Settings app in 
the search results. ... 

2. Click on the Ease of Access menu option. ... 

3. Under Display, use the slider under the Make text bigger heading to adjust the 
text to the size you want it. 

 

 

C ].  To change the font color 
 

Select the text that you'd like to change the font color. Then select the Home tab in 
the toolbar at the top of the screen. Then click on the arrow to the right of the Font 

Color button  in the Font group. A popup window should appear. Select the 
color that you'd like your text to be. In this example, we've selected a Red color. 

 
 

 
 



 

D]. To highlight (in yellow) the line that reads “need to get IMS’s address”. 

 

1. Click the Home tab. 
2. In the Font group, click the Text Highlight button. 
3    Drag the mouse over the text you want to highlight. 

      4   The text becomes highlighted — just as if you used a highlighter on       
regular paper but far neater. 

4. Click the Text Highlight button again to return the mouse to normal 
operation. Or press the Esc key to exit Highlighting mode. 
 

 

 

Q7. Create a file in MS-Word for the following document and save it with file 
name ‘ms_word’. Describe all steps involved in it. 

A.To create a new document: 

1. Click the Microsoft Office button. 
2. Select New. The New Document dialog box appears. 
3. Select Blank document under the Blank and recent section. It will be 

highlighted by default. 
4. Click Create. A new blank document appears in the Word window. 

B.To save a document: 

1. From the File menu, select Save As… 
2. The Save As dialog box will display. 
3. Choose a location on your computer to save your file. ... 
4. Next to File Type is a drop down menu; select Rich Text Format (.rtf) or 

Microsoft Word (*.doc). 
5. Click Save. 

 
 

Q14 b) Write the steps for the following action for creation of 
power point presentation 

 Open a Blank presentation 

 Save the presentation as Lab1.pptx 

 Add a Title to the first slide: the name of your college 



 Type your first name and last name in the Subtitle section 

 Add a New Slide which has a Title and Content 

 

 

When beginning a new project in PowerPoint, you'll often want to start with a 
new blank presentation. 

1. Select the File tab to go to Backstage view. 

2. Select New on the left side of the window, then click Blank Presentation. 

3. A new presentation will appear. 

 

The following are the basic steps to save a presentation. 

1. Step 1 − Click on the File tab to launch the Backstage view and select Save. 

2. Step 2 − In the Save As dialog, type in the file name and click "Save". 

3. Step 3 − The default file format is . pptx. 

How do you add a title to a slide? 

4. 4. To add a slide title to an existing slide go to the “Home” tab and click 
“Layout” then “Title Only”. 5. Then place your cursor in the “Click to add 
title” box on the slide and type in your unique slide title. 

 
 
First and Last Name Title of Presentation Place, Date 
Instructions for editing personal data in the footer1. Select the "View" tab 

2. Select "Slide Master" in the "Master Views" topic area 

3. On the first slide (go back one slide), click the lower text box, and edit the personal entries 

4. Close Master View: In the "View" tab select "normal" in the “Presentation Views” topic 
area. 

5. Now the adapted footer texts can be seen on all pages 

6. The footer entries can be changed again in the same way 

7. Delete this instruction text and edit the title pageFirst and Last NameTitle of 
PresentationPlace, Date. 

 

9].  Create a file in MS-word that convert existing 
highlight text to table as shown below and    save it as 

file name ‘text_to_table’. Describe all steps involved in it.  



 

 

Insert separator characters—such as commas or tabs—to indicate where to divide the text 
into table columns. 

 

Use paragraph marks to indicate where you want to begin a new table row. 

In this example, the tabs and paragraph marks will produce a table with 3 columns 
and 2 rows: 

3.  Select the text that you want to convert, and then click Insert > Table > Convert 
Text to Table. 

 

4. In the Convert Text to Table box, choose the options you want. 

 



Under Table size, make sure the numbers match the numbers of columns and rows 
you want. 

Under AutoFit behavior, choose how you want your table to look. Word 
automatically chooses a width for the table columns. If you want a different column 
width, choose one of these options: 

1. Under Separate text at, choose the separator character you used in the text. 

2. Click OK. The text converted to a table should look something like this: 

 

Q19. Describe the syntax of the following statements 

a) If – else statement  b) for loop c) while loop d) do-while loop 

 

a) a) If – else statement  

 

If...else if...else Statement 

An if statement can be followed by an optional else if...else statement, which is very 
useful to test various conditions using single if...else if statement. 

When using if...else if..else statements, there are few points to keep in mind − 

 An if can have zero or one else's and it must come after any else if's. 

 An if can have zero to many else if's and they must come before the else. 

 Once an else if succeeds, none of the remaining else if's or else's will be tested. 

Syntax 

The syntax of an if...else if...else statement in C programming language is − 

if(boolean_expression 1) { 

   /* Executes when the boolean expression 1 is true */ 

} else if( boolean_expression 2) { 

   /* Executes when the boolean expression 2 is true */ 

} else if( boolean_expression 3) { 

   /* Executes when the boolean expression 3 is true */ 



} else { 

   /* executes when the none of the above condition is true */ 

} 

b) for loop  

 

A for loop enables a particular set of conditions to be executed repeatedly until a condition is 
satisfied. Imagine a situation where you would have to print numbers from 1 to 100. What would 
you do? Will you type in the printf command a hundred times or try to copy/paste it? This simple 
task would take an eternity. Using a for loop you can perform this action in three statements. This is 
the most basic example of the for loop. It can also be used in many advanced scenarios depending 
on the problem statement. 

 

Syntax of a For Loop 
1. for (initialization statement; test expression; update statement) { 
2.  // statements 
3. } 

The for loop starts with a for statement followed by a set of parameters inside the 
parenthesis. The for statement is in lower case. Please note that this is case sensitive, which 
means the for command always has to be in lower case in C programming language. 
The initialization statement describes the starting point of the loop, where the loop 
variable is initialized with a starting value. A loop variable or counter is simply a variable that 
controls the flow of the loop. The test expression is the condition until when the loop is 
repeated. Update statement is usually the number by which the loop variable is 
incremented. 

 



 c) while loop  

 

C – while loop 

Syntax of while loop: 

while (condition test) 
{ 
      //Statements to be executed repeatedly  
      // Increment (++) or Decrement (--) Operation 
} 

Flow Diagram of while loop 

 

 

Example of while loop 

#include <stdio.h> 
int main() 
{ 
   int count=1; 
   while (count <= 4) 
   { 
 printf("%d ", count); 
 count++; 
   } 
   return 0; 
} 
Output: 

Q10. Create a file in MS-Word to insert a table in the document. Describe 
all steps involved in it. 

How to Insert Table in MS Word 



Table is a versatile tool of MS Word. It allows you to organize your information, i.e. you 
can align text, present numerical data and create forms and calendar. The steps to insert 
table are given below; 

o Place the cursor where you want to insert the table 

o Select the Insert tab 

o In Tables group click the Table command 

o It displays different options to insert the table 

o Select the desired option to insert the table 

 

 

To Convert Text to Table 

o Select the text 

o Select the Insert tab 

o In Tables group click the Table command 

o Select the 'Convert Text to Table' option; 

 

 



o It displays a dialog box 

o In 'Separate text at' section select the desired option 

o Click OK, the text will convert to a table 

See this image: 

 

How to Add Row in Table 

If you want to increase or add a new row in your table, you can follow the steps given 
below; 

o Place the cursor in a row above or below which you want to add row 

o Right click the mouse 

o A menu appears 

o Place the arrow over Insert option 

o It will display a menu 

o As required select 'Insert Rows Above' or 'Insert Rows Below' 

 



 


