
CCA-101: Fundamentals of 
IT & Programming 

 

Assignment – 1 
 

Q1: What are the four fundamental parts of 
computer? Explain it with the help of diagram. 

Ans: -         

 

 

 

Q2: Discuss about the classification of computers 
based on size and capacity. 

Ans: -  

  Classification of computer based on size and capacity is in Five 
Types:  

1) Supercomputer 
2) Mainframe Computer 
3) Minicomputer 
4) Microcomputer 
5) PC (Personal Computer) 



Q3: What is the meaning of computer generation? 
How many Computer Generations are defined? 
What technologies were/are used? 

Ans: - 

 The evolution of computing is divided into a generation. 

Computer generations are defined in five generation: 

1) First generation (Vacuum Tube) 
2) Second generation (Transistors) 
3) Third generation (Integrated Circuits) 
4) Fourth generation (Microprocessors) 
5) Fifth generation (Artificial Intelligence) 

 Quantum computation and Nanotechnology were used. 

 

 

Q4: Differentiate between Volatile & Non- Volatile 
memories. 

Ans: -  

              Volatile               Non-Volatile 
Volatile memory is a main 
memory of computer.  

Non-Volatile memory is 
secondary memory of 
computer. 

Volatile memory is Fast.  Non-Volatile memory is slower 
than volatile memory. 

Volatile memory is Temperary 
memory of computer. 

Non-Volatile memory is 
Permanent memory of 
computer. 

Volatile memory is known as 
RAM. 

Non-Volatile memory is known 
as ROM. 

 

 

 

 

 

 



Q5: Distinguish among system software, application 
software and open-source software based on their 
features. 

Ans: -  It is a type of software that is design to run a computer’s 
hardware and application programs. 

System Software Application 
Software 

Open-source 
Software 

System software 
mainly design for 
managing system 
resources. 

Application software 
are design to 
accomplish tasks for 
specific purposes. 

It is customizable 
depending on 
software license. 

Programming of 
system software is 
complex. 
 

Programming of 
application software 
is comparatively 
easy. 

It is available for 
zero licensing and 
usage charges. 

A computer cannot 
run without system 
software. 

A computer can 
easily run without 
application 
software. 

The user-friendliness 
depends on the 
projects and the 
community 
maintaining them. 

System software do 
not depend on 
application 
software. 

Application software 
depend on system 
software and cannot 
run without system 
software. 

As mainly users 
continuously 
analyze the open-
source software, it is 
easy to detect the 
bug and rectify 
them. 

 

Q6. a) Create a file in MS-word to insert a 
paragraph about yourself and save it with file 
name “yourself”. Describe all steps involved in 
it. 

Ans: -                    Myself 

  My name is Manish. My mother and father give me this name. 
I love my name. I am Twenty years old and studying in diploma. I 
live in Maharashtra; it is counted among the richest and prosperous 
state of India. In my family, we are Five members. I have two 
younger brothers. My father is businessman, and My mother is 
homemaker. I love my family with the core of my heart. My hobbies 
are drawing, hangout with best friend and playing online games. 
My aim is Master the coding and making a best software in the 
world. 



Q6 b) Write steps regarding followings. 

➢  To change the font style. 
➢  To change the font size. 
➢  To change the font colour. 
➢  To highlight (in yellow) the line that reads 

“need to get IMS’s address”. 

Ans: -  

❖ To change the font style:  
1. Select the text you want to change their font. 
2. Select home from menu bar. 
3. Select font column. 
4. Select font column. 
5. Select which font you want, and press Enter. 

❖ To Change the font size: 
1. Select the text you want to change their font 

size. 
2. Select home from menu bar. 
3. Select font column. 
4. Select size column. 
5. Change size and press Enter. 

❖ To change the font colour: 
1. Select the text you want to change their font 

colour. 
2. Select home from menu bar. 
3. Select font column. 
4. Select font colour and press Enter. 

❖ To highlight (in yellow) the line that reads 
“need to get IMS’s address”: 

1. Select the line you want to highlight. 
2.  Select home from menu bar. 
3. Select font column. 
4. Select which colour you want, and press 

Enter. 

 



Q7. Create a file in MS-Word for the following 
document and save it with file name ‘ms_word’. 
Describe all steps involved in it. 

Ans: - 

 MS Word 

 MS Word is a widely used commercial word processor 

developed by Microsoft. 

MS Word is application software, which is capable of 

• Creating, 

• Editing, 

•  Saving, and 

•  Printing any type of document 

 

 

Q8. Create a file in MS-word for the following 
document and save it with file name ‘equations’. 
Describe all steps involved in it. 

Ans: - 

  

Equations 

       X2 + Y5 = 30 

   Z3 + Q4 = 50 

   A2 + B8 = X2 + Y8 

 

 

 



Q9. Create a file in MS-word that convert existing 
highlight text to table as shown below and save it 
as file name ‘text_to_table’. Describe all steps 
involved in it. 

Ans: - 

Select the text you want to convert. 
 Select the Insert tab. 
 Click on Table command. A dialog box appears. 
 Click on Convert Text to Table, a new dialog box appears. 
 Here set numbers of columns. 
 Click on OK Finally Selected text converted in a table. 
 
 
  

Select the text you want to 
convert. 

Select the Insert tab. 

Click on Table command. A 
dialog box appears. 

Click on Convert Text to 
Table, a new dialog box 
appears. 

Here set numbers of columns. Click on OK Finally Selected 
text converted in a table. 

 
Q10. Create a file in MS-Word to insert a table in the 
document. Describe all steps involved in it. 
Ans: - 
        First step to add table: - 

1) Select the Insert tab from menu bar. 
2) Select the table column. 
3) Select insert table option. 
4) Select Table size. 
5) Then select number of column and number of rows you 

want to add. 
6) Then click OK now your table is inserted. 

OR 
        Second step to add table: - 

1) Select the Insert tab from menu bar. 
2) Select the table column. 
3) Select Draw the table. 
4) Then draw your table. 

OR 
  Third step to add table: - 

1) Select the Insert tab from menu bar. 



2) Select the table column. 
3) Select how many tables you want to add. 

 
Q11. Create a following worksheet in MS-excel and 
save it with name ‘book1’. 
Ans: - 
 

  
 
 
 
Q12. Calculate the following things of a range (C2:C11) 
of data in the worksheet created in question no 
10. 
➢  the sum of the marks using AutoSum in a range 

of cells (C2:C11) 
➢  average of the marks in a range of cells (C2:C11) 
➢  highest marks in a range of cells (C2:C11) 
➢  minimum marks in a range of cells (C2:C11) 

Ans: - 
 

  



Q13 a) Describe various steps involved in the 
following. 
➢  To modify column width of a worksheet. 
➢  To modify the row height of a worksheet. 
➢  To delete rows and columns of a worksheet. 

Ans: - 
➢ To modify column width of a worksheet. 

1) Select the Home tab from menu bar. 
2) Select the Cells column. 
3) Select Format option on cells column. 
4) Select column width. 
5) Enter the width. 
6) Then click OK now your column width is changed. 

 

➢ To modify the row height of a worksheet. 
1) Select the Home tab from menu bar. 
2) Select the Cells column. 
3) Select Format option on cells column. 
4) Select row height. 
5) Enter the height. 
6) Then click OK now your row height is changed. 

 

➢ To delete rows and columns of a worksheet. 
1) Select which row or column you want to delete. 
2) Select the Home tab from menu bar. 
3) Select the Cells column. 
4) Select Delete option on cells column. 
5) Click on delete row or delete column you want to delete. 
6) Now your row or column was deleted. 

 

Q13 b) Describe following terms in the worksheet. 

➢  Absolute reference and relative reference in 
formula 

➢  Cell address  

Ans: - 

➢ Absolute reference and relative reference in 
formula: -   

Relative references change when a formula is copied to another 
cell. Absolute references, on the other hand, remain constant no 
matter where they are copied. 



➢ Cell address  

    A reference is a cell's address. It identifies a cell or range of cells 
by referring to the column letter and row number of the cells. 

 

Q14. a) What tools are available to customize our 
PowerPoint presentation? 

Ans: - 

1)  Templates and Themes. 
2)  Slides Layouts. 
3)  Colour Themes. 
4)  Icons and Shapes. 
5)  Charts and Graphs. 
6)  Tables. 
7)  Radials. 
8)  Animation. 
9)  Transitions. 
10)  Audio and Video. 

 

Q14 b) Write the steps for the following action for 
creation of power point presentation. 

➢ Open a Blank presentation. 
➢ Save the presentation as Lab1.pptx. 
➢ Add a Title to the first slide: the name of your 

college. 
➢ Type your first name and last name in the 

Subtitle section. 
➢ Add a New Slide which has a Title and 

Content.  

Ans: - 

➢ Open a Blank presentation. 
1) Click on File tab from menu bar. 
2) Select blank presentation. 
3) Now your blank presentation is open. 

 

➢ Save the presentation as Lab1.pptx. 
1) Click on File tab from menu bar. 



2) Select save option and choose in which folder your 
want to save your file. 

3) Give the name for your file and click OK. 
4) Now your file is saved. 

 

➢ Add a Title to the first slide: the name of your 
college. 
1) Click on Power-point and open blank presentation. 
2) Now click on “click to Add title” option. 
3) Write what title you want to write. 

 

➢ Type your first name and last name in the Subtitle 
section. 
1) Click on power-point and open blank presentation. 
2) Now click on “click to add subtitle” option. 
3) Write what subtitle you want to write. 

 

➢ Add a New Slide which has a Title and Content.  
1) Click on Home tab from menu bar. 
2) Select slides column. 
3) Then select new slides option on Slides. 
4) Click on Title and Content. 
5) Now your Title and Content slide is added to your 

presentation. 

 

Q15. Write steps for creation of a set of PowerPoint 
slides that demonstrates your skill to use the tools of 
PowerPoint. It should include the following things. 

➢  Title slide & bullet list 
➢  Inserting Excel Sheet 
➢  Clip art and Text 
➢  Slide show effects 

Ans: - 

➢ Title slide & bullet list 
• Title Slide 

1) Select Home tab from menu bar. 
2) Select Slide column. 



3) Then select new slide option on slides. 
4) Click on Title slide now your title slide is open. 

• Bullet list 
1) Select Home tab from menu bar. 
2) Select paragraph column. 
3) Select bullet list now your bullet list is added. 

 

➢  Inserting Excel Sheet 
1) Select Insert tab from menu bar. 
2) Select Tables column. 
3) Select on table and click excel spreadsheet. 
4) Now your excel sheet is added. 

 

 

➢  Clip art and Text 
• Clip art 

1) Click in the slide where you want to insert a clip 
art. 

2) Select insert tab from menu bar. 
3) Select Images column and click on pictures. 
4) Select where you saved your clip art. 
5) Click OK Now your clip art is added. 

• Text 
1) Select insert tab from menu bar. 
2) Select Text column. 
3) Select text box in text column. 
4) Then click on your slide now your text box is 

added. 
 
 

➢  Slide show effects 
1) Select slide your want to add animate. 
2) Select Transitions tab on menu bar. 
3) Add which transition you want to add. 
4) Now your slide show effects is added. 

 

 

 

 



Part – 2 

Q16. What is the difference between Machine 
Language and High-Level Language? 

Ans: - 

 

   Low-Level Language    High-Level Language 
Direct memory management. These are interpreted. 
Hardware has extremely little 
abstraction which is actually 
close to having none. 

They have open classes and 
message-style method which is 
known as Dynamic constructs. 

Much faster than High-level 
language. 

Poor performance. 

Statement corresponds directly 
to clock cycle. 

Code is concise. 

Superb performance but hard to 
write. 

Flexible syntax and easy to 
read. 

Few supports and hard learn. Is object oriented and 
functional. 

 

 

 

 

Q17. Discuss about different data types of C 
programming Language. 

Ans: -  

           Each variable in C has an associated data type. Each data 
type requires different amounts of memory and has some specific 
operations which can be performed over it. It specific the type of 
data that the variable can store like integer, character, floating, 
double, etc. The data type is a collection of data with values having 
fixed values meaning as well as its characteristics. 

Some data types: - 

Type Specification Format   
Specifier 

Range of 
values 

Integer int %d -32,768 to 32,767 
Floating Point Float %f 3.4E +/-38 
Character Char %c -128 to 127 
Double double %lf 1.7E +/-308 



 

Q18. Find the output of the following expressions. 

a) X=20/5*2+30-5  

b) Y=30 – (40/10+6) +10  

c) Z= 40*2/10-2+10 

Ans: - 

a)  X=20/5*2+30-5  

X = 4*2+30-5 

X = 8+30-5 

X = 38-5 

      X = 33 

b)  Y= 30 – (40/10+6) +10  

Y = 30 – (4 + 6) + 10 

Y = 30 – 10 + 10 

Y = 30 – 0 

      Y = 30 

c)  Z= 40*2/10-2+10 

Z = 40 * 0.2 – 2 + 10 

Z = 8 – 2 + 10 

Z = 18 - 2 

      Z = 16 

Q19. Describe the syntax of the following statements. 

a)  If – else statement  
b)  for loop  
c) while loop  
d) do-while loop  

Ans: - 

 

a) If – else statement: 

            if(expression) 



                { 

                   Block of Statement 

                     } 

            Else 

                { 

                   Block of Statement 

                } 

    

b)  for loop: 

                for (expression 1; expression 2; expression 3) 

                    { 

                       Single statement  

                       Or 

                       Block Statement 

                    } 

 

c) while loop: 

               While(expression) 

                   { 

                      Single statement 

                      Or 

                      Block Statement 

                  } 

 

 
 
 

d) do-while loop: 

            do 

               { 

                 Single statement 



                 Or 

                 Block Statement 

               } 

             While(expression); 

 

Q20. Find the output of the following program 
segments. 

a)   
 

b) 
 

c) 
 

#include <stdio.h> 
int main () 
{ 
int i; 
for (i=1; i<2; i++) 
{ 
printf (“IMS 
Ghaziabad\n"); 
} 
} 
 

#include <stdio.h> 
int main () 
{ 
int i = 1; 
while (i <= 2 ) 
{ 
printf(“IMS 
Ghaziabad\n"); 
i = i + 1; 
} 
} 
 

#include <stdio.h> 
void main () 
{ 
int a = 10, b=100; 
if(a > b ) 
printf(“Largest 
number is %d\n”, a); 
else 
printf(“Largest 
number is %d\n”, b); 
} 
 

 

Ans: - 

a) : 
IMS Ghaziabad 
 

b) : 
IMS Ghaziabad 
IMS Ghaziabad 
 

c) : 
Largest number is 100. 

 


