Analyzing Data Using Excel

What you will do:

Create a
spreadsheet

Use formulas and
basic formatting

Import text files

Save worksheets
as web pages

Add interactivity to
web worksheets

Use pivot tables
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Create charts
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Analyzing data is an important skill for any professional to possess. The existence of
data in its raw collected state has very little use without some sort of processing.
Examples of this are the answers to quiz questions that are collected from students.
If no further examination of the quiz answers is undertaken, you will not know if the
students passed or failed. Further, you would not know how one student performed
as opposed to another. Excel can assist you in this analysis of data. You can grade
the students’ results and chart their progress. You can even allow the modification of
data through web pages. If you teach, you keep student data; so make the most of
your available data and use it efficiently by evaluating that data with Excel.

In this workshop you will learn to use the features in Excel 2000 to track student
progress and analyze general data. You will import the textual results of an online
quiz. You will also create a spreadsheet to analyze that data. Collaborative
enhancements to spreadsheets will be used such as saving worksheets as web
pages and adding interactivity. You will also import survey data and analyze it with
pivot tables and charts. Let’'s make use of your data by analyzing it, today!

Before You Begin

Excel is Microsoft’s popular spreadsheet software that enables the calculation and
display of complex mathematical formulas. Extensive formatting is available to
customize the viewing of these calculations as well. It imports data from a variety of
sources. Internet Explorer 5 adds new web discussion features that enable you to
take your documents that have been saved as web pages and hold discussions on
them and even take advantage of interactivity that may be added to the web page.
The web-based documents can then round trip those documents back into Excel for
editing using the familiar environment used to create the document in the first place.
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Words to know:

HTML-HyperText Markup
Language—Language use to
format Web pages.

Browser—A program that
allows viewing of HTML
formatted documents (Web
pages).

Function—A predefined
calculation that may be
included in a cell and does a
specific manipulation of data.

PivotTable—A special type of
worksheet used to summarize
and manipulate data.

Microsoft® Excel—
Spreadsheet application that
includes natural language
formulas, data importing,
charting, extensive formatting,
and many other features.
Integrates seamlessly with the
other Microsoft® Office family
of applications.

Microsoft® Office Server
Extensions—A collection of
services that allow inline
discussions and the
treatment of web folders as a
normal file location for saving
and opening documents. It is
fully integrated with the
Microsoft Office family of
applications.

Microsoft® Internet Explorer
5.0—The latest version of
Microsoft’s popular web
browser. It allows editing and
displaying of web pages,
collaboration on standard
office documents through
discussions, and round
tripping.

Touring Excel

Before you start using Excel 2000, become familiar with its features. The following
illustration shows a new worksheet:
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Using Excel

As an instructor, you have given quizzes, tests, and surveys over the web. You now
have data files that are the responses to the questions in a quiz and you need to
grade those responses. You choose to use Excel to import the data into and analyze
it, resulting in the automation of grading the quizzes. You also examine the results of
the quiz to discover what questions the students may need review on. The student
grades are then posted to the class web site to allow them to see the results of their
efforts.

Importing Data

Data exists in an infinite number of formats and repositories. Incorporating external
data into a spreadsheet is an essential time saving task. There is no need to re-key
existing electronically stored data; you may just import it. Of course Excel can’t
possibly read all types of data formats that exist, but most applications can save their
data as a delimited text file. The delimited part of the name indicates that each
section of data is separated or delimited by some sort of special character. The
comma, quote, and space are very common delimiters. The data can then be
interpreted from this file and imported into Excel. You are going to import the results
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of a web-based quiz and survey, later we will analyze the data to summarize the

results.

To Import a Delimited Text File

1

2.

Click on tab named Sheet 2 to switch to that sheet.

Rename the sheet by right clicking on the tab and selecting Rename.
Type in the name of Quiz1.

On the Tools menu select Get External Data and click Import Text File.
Navigate to the file you wish to import (quiz1.txt for the lab).
Double click on the file

_Or-
Click once on the file and click Import.

6. The Import Text Wizard will begin. Click Next to accept a delimited text
file and start importing at row 1
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7. On step two the delimiter should be a tab and the data should be

organized and readable in the Data preview box. Click Next.

8. Click Finish on step three to accept the general data format and

complete the wizard.

9. Onthe Import Data dialog, click OK to put the data on the existing

worksheet.
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Creating a spreadsheet

This section describes how to create a spreadsheet and modify it to suit your needs.
You will use formulas and formatting as well as embed a chart. You will prepare the
sheet to be saved as a web page.

To Create a Worksheet

1. Click Worksheet from the Insert menu.

2. Right click on the tab for the new worksheet and select Rename from
the shortcut menu.

3. Type in Grade Book and press Enter to save the change.
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4. Key in text into the worksheet as shown in the picture above. You may
use different names and grades as you see fit.

5. Once you have all the data in, save your work by clicking Save from the
File menu.
_or-
Click on the Save button on the toolbar.
To Enter Formulas and Functions

1. Incell H3 type in Total Score.

2. You will now type in the formula for calculating the total score for the
student. In cell H4 type in =(D4+E4+F4+G4)/4 and press Enter.
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3. Position your mouse cursor over the fill handle (Small black box in the
lower right hand corner of the active cell).

4. Click and hold, drag down to cell H9 and release. This replicates the
formula for the rest of the students in the list. If you have more
students, simply drag the mouse down to the last row that has a

OP TEN student and release there.
d

You may give a 5. You may also wish to calculate the average for each graded item. Select
common look and feel cell D10 and from the Insert menu click Function.

to your entire o

document by assigning 6. Select AVERAGE in the Function name box and click OK.

a theme. This also

makes the document

more acceptable in a 7. The range you wish to use will already be entered, so click OK.
web format should you

choose to save itas a

web page.
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8. Again drag the fill handle to the last filled in column (cell H10 in the lab)
and release. Notice the value in cell F10 is #DIV/0!. This is due to the
fact that there is no data in that column that is being averaged.

9. Enter 1 for all the exam grades in order for the function in cell F10 to
calculate properly.

To Format Your Worksheet

1. Select all the cells that encompass your title (A1:E1) and click the down
arrow to the right of the Fill Color button. Select the desired color.

2. Select your grade book by clicking and holding in cell A3 and dragging
to cellH10 and releasing.

3. Select AutoFormat from the Format menu and select the desired format
from those provided. (Colorful 2 is fine). Click OK.
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4. IncellA10 type AVG.

5. Save your work by clicking Save from the File menu.

_or-
Click on the Save button on the toolbar.

To Embed a Chart
1.  Highlight cell C3 to H9.

2. Click Chart from the Insert menu and select the chart type that you

desire from the list provided.

3. Click Next to advance to the subsequent step and click Next again.

4. Type in atitle in the Chart Title box and type in Student ID for the X axis

label.
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5. Click Finish to complete the wizard and position the chart as necessary.

6. Save your work.

Web Enabling Your Worksheets

Now that you have created a worksheet and formatted it appropriately, it's time to
offer it to others for use. Excel can save natively to web based formats as easy as you
can save to your hard drive. You can also add interactivity to your worksheet, allowing
others to modify the data you originally entered and immediately visualize the
outcome. Your students are going to access the grade book you just created to see
their current grades. You will also provide interactivity with the grade book that will
allow them to input exam grades and see what they need to really score to obtain the
desired grade in your class.

To Save as Web Page
1. Select cell C3 to D9 and select Copy from the Edit menu.
2. Activate Sheetl by clicking on its tab and click in cell A3.

3. Select Paste from the Edit menu, which will paste the student IDs and
their homework grades into the sheet.

4. Incell A1 type Homework Grades and change the font size to 16.
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5.

EA Microsoft Excel - quizl.xls

Click Save as Web Page from the File menu and select the Desktop
button on the bar on the left of the dialog.
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6. Type a name for your file in the File name box.
7. Select the radio button next to Publish:Sheet and click Save.
8. Minimize all the open applications on your system and double click on

the .htm file you created on the desktop. (It will be named by the file
name you entered in step 6.)

To Save as Web Page with Interactivity

1

Activate the sheet you wish to save by clicking on the appropriate tab
(Grade book for the lab).

Select the chart you created and click Save as Web Page from the File
menu.

Select the Desktop button on the bar on the left of the dialog and type
a name for your file in the File name box.

Select the radio button next to Publish:Chart and select the check box
beside Add interactivity.

Click the Save button to generate the web page.
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6. Minimize all the open applications on your system and double click on
the .htm file you created on the desktop. (It will be named by the file
name you entered in step 2.)
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You will see the chart above and the supporting data below. The first student
wishes to end up with at least a 93 for the class. Enter values for the exam
on that student’s line until the total score becomes at least 93. Notice that
as you fill in the exam grades the chart above dynamically changes to reflect
the changes in the worksheet. You may export data collected in one of these
worksheets to Excel with the Export to Excel button.

Using PivotTables and Charts

PivotTables are extremely powerful tools for data analysis and pivot charts allow the
visualization of that analysis. You will create a pivot table and chart of the data
collected from a web survey. This will allow you to find useful information about the
patterns in the data and communicate those findings through a graphical means. An
example of the use of a PivotTable would involve the financial data at your institution.
The income and expenses are stored in a table with each record or entry having an
amount, a payee/payor, an account, and a month. To evaluate the year to date
budget, a pivot table could be created. The month would become the column
headings, the account would become the row headings and the amounts would
become the value items for each row-column intersection. The result would show the
dollar volume for each account on a month-by-month basis. Obviously, this is a very
useful way to organize the data. For the trustees meeting, we could create a
PivotChart of the data allowing the graphical display of the financial data. Remember,
a picture is worth a thousand words.
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To Create a PivotTable
1. Click on tab named Sheet 3 to switch to that sheet.

2. Rename the sheet by right clicking on the tab and selecting Rename.
Type in the name of Survey

3. Onthe Data menu select Get External Data and click Import Text File.
4. Navigate to the file you wish to import (results.txt for the lab).
5. Double click on the file

_Or'_

Click once on the file and click Import.

6. The Import Text Wizard will begin. Click Next to accept a delimited text
file and start importing at row 1

7. On step two the delimiter should be a comma and the data should be
organized and readable in the Data preview box. Click Next.

8. Click Finish on step three to accept the general data format and
complete the wizard.

9. Onthe Import Data dialog, click OK to put the data on the existing
worksheet.

10. Select from A1 to H21 on the worksheet and click PivotTable and
PivotChart Report from the Data menu.
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11. Click Next, to accept the analysis of Excel data using a PivotTable.
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12. You can click Next on step 2, because you selected the range for the
PivotTable before starting the wizard.

13. Click Finish, to place the PivotTable in a new worksheet.
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14. Rename the worksheet to Analysis.

15. Drag and drop Gender from the PivotTable dialog to the Drop Column
Fields Here range.

16. Dragand drop Age from the PivotTable dialog to the Drop Row Fields
Here range.

17. Drag and drop OwnPC from the PivotTable dialog to the Drop Data
Items Here range.
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18. Right click on the Age button in cell A4 select Group and Outline and
select Group.
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19. Enter 15 in the Starting at box and 75 in the Ending at box.

20. Make sure 10 is in the By box and click OK. This will group the ages
with ten years in each division.

Your pivot table now shows the number of women and men by age group
that own computers. You also wish to quantify the percentage of women that
own computers at each age group. A few simple calculations will display the

answer to this question for you as well.

21. Select cellE3 and type % Females that.

22. Select cell E4 and type own PCs.

23. In cell E5 type in =B5/COUNTIF(Analysis!$D$2:$D$21,"F"). This formula
calculates the percentage by dividing the number of women in a
particular age group (B5) by the total number of women
(COUNTIF(Analysis!$D$2:$D$21,"F").

24. Click on the fill handle in cell ES and drag it to cell E11 and drop it. This
replicates the formula for the rest of the rows.

25. Format the borders of the new column to match those of the
PivotTable.

You may drag and drop items on and off the PivotTable to re-pivot the table
thereby answering another question. For instance, you may wish to know
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what major would people be more likely to own a computer or how old are
the computers that women own versus the computers that men own. You
really get complex data analysis without a great deal of work.

To Display Analyzed Data with a PivotChart

1. Click on the Chart Wizard button in the PivotTable dialog and the
PivotChart will be instantly created.

2. The wizard makes a best guess as to the chart type and the formatting
characteristics. Right click on the chart and select Chart Type to bring
up the Chart Type dialog.

3.  You may select different chart types and then press the Press and Hold
to View Sample button to see what your data would look like in that
format.

4. Click OK when you have made your selection.

Take some time to
experiment with charts. J@ Ele Edt Yiew Insert Format Tools Chart Window Help =15 x|
They are very powerful IDzE&e fao- (&= s limE 7| o slmro|l===|i]-d.7
tools for communicating | Chart Area =] =]

information as long as the T Drop Pace Feids Here T
appropriate type is used to
format the data. Different Survey Respondants YWho Own PCs
sets of data need to be Chart Area

displayed to best convey
their results, so make sure
the chart type and layout
you have selected makes
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being analyzed.
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You may customize the PivotChart as you see fit. Keep in mind that you may
also change the underlying PivotTable by dragging and dropping fields from
the PivotTable dialog on to or off of the chart. Any fields that appear on the
chart with a drop down arrow on them will allow you to turn off the display of
individual data items in them. You could have this chart show just the
women that owned PCs using this feature.

To Save PivotTables and Charts to Web Pages
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1. With the appropriate sheet active select Save as Web Page from the
File menu.

2. Select Desktop as the saving location and type in the name for your
page in the File Name box.

3. Select the Selection radio button and check the Add interactivity check
box.

4. Click the Save button to complete the process.

5.  Minimize all the open applications on your system and double click on
the .htm file you created on the desktop. (It will be named by the file
name you entered in step 2.)
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IAgdress I@ CAWINNT Profileshadministiator. 000D esktop\Pivat example. htm j PGU “ Links #
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w44
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PivotTabled

Dirop Filter Fields Here
Gender |
EF [E M |E Grand Total |
Age v [Mame +[ID = [CwnPC » [PCage * [Platform ¥ [Major ~ [Count of OwnPC [Count of OwnPC|
=18 0 0
8 19 |Frances Wolf 197582 on T UNI= Engineering | 0 1
Courit of OwnPC 1
=22 1 1
B 26 |Alicia Green 585312 on 1 Windows  Marketing | 1 2
Count of OwnPC 1
B 29 |Stephanie DuBois 126584 on 1 UNIE Engineering | 1
Count of OwnPC 1 ||
B30 |Betsy Massey  |BBEST4 on 1Windows | Political Science| 1
Count of OwnPC 1
B35 |Mary Williams 386756 an 2 Windows  Chemistry | 1
Count of OwnPC 1
=337 1 1
B 43 |Mary Jones 785586 Education | i} =l
I@ ’_’_ |E by Computer

Interactivity in a PivotChart saved as a web page allows you to expand and
contract the columns of data to see the individual record for each item.
Notice, however, that the groupings you applied are not retained when the
chart is saved as a web page.

Getting Help

At any time while you are using Excel, you can get help from the Help menu. To open
the online Help, click Microsoft Excel Help on the Help menu. If you have an Internet
connection, you can also point to Office on the Web on the Help menu and choose
from several resources that may be of interest to you such as Product News,
Frequently Asked Questions, and Online Support. Don’t forget to go to
http://www.microsoft.com/excel for all the latest information.
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